[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[bluetooth-dev] Ericsson BDK and Axis stack



Hello,
I try to make it run all together: EBDK and Axis software. My set-up includes two Linux PCs and E/// modules.
The compilation went fine except these warning messages:

sdp.c:180: warning: initialization from incompatible pointer type
sdp.c:181: warning: initialization from incompatible pointer type
sdp.c:577: warning: `send_error_rsp' defined but not used

The client site seams to be OK:

btd --reset --speed 115200 -i ericsson -r clientBluetooth Control Application-----------------------------
Please reset HW board within 5 seconds
Running as client
Physdev /dev/ttyS0, btdev /dev/ttyBT0, speed 115200 baud
Opening dev /dev/ttyS0
Initiating physical driver
Initializing Ericsson HW
Registered bluetooth line discipline on /dev/ttyS0
Opening dev /dev/ttyBTC
Init stack
Setting write_scan_enable in Ericsson module!
Setting baudrate in Ericsson module!
Opening dev /dev/ttyBT0Now entering cmd line mode
Menu
------------------------
  inq (inquiry scan)
  con <xx:xx:xx:xx:xx:xx> <line> <server channel> <profile>
  disc <handle>  
  send <nbr bytes> <nbr repeats>
  me <1/0>
  setbd <xx:xx:xx:xx:xx:xx>
  readbd
  reset
  ecs_entertest <handle> (hex)
  ecs_testctrl <par1,par2,...,par9> (hex)
  ecs_txtest   <par1,par2,...,par11> (hex)
  ecs_testcon <xx:xx:xx:xx:xx:xx> (hex)
  enable_dut
  ppp
  quit
> 

First question however is what are these new commands and parameters not described in the README file?
The main problem I have got is at server site:

btd --reset --speed 115200 -i ericsson
Bluetooth Control Application
-----------------------------
Please reset HW board within 5 seconds
Running as server
Physdev /dev/ttyS0, btdev /dev/ttyBT0, speed 115200 baud
Opening dev /dev/ttyS0
Initiating physical driver
Initializing Ericsson HW
Registered bluetooth line discipline on /dev/ttyS0
Opening dev /dev/ttyBTC
Init stack
Setting write_scan_enable in Ericsson module!
Setting baudrate in Ericsson module!
Opening dev /dev/ttyBT0

that's it, no response later on.

Any suggestions are welcome and will be appreciated. I try to set up deferent UART speed - it does not help.
Regards,
Piotr
-
To unsubscribe from this list: send the line "unsubscribe bluetooth-dev" in
the body of a message to majordomo@xxxxxxx.com