[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [bluetooth-dev] Evaluations of Axis bluetooth_20001031 and _1115. with null modem



I tried with the kernel mode, handle 0 is returned however when i try to
test the rfcomm layer by "send 100 10". The debug message give CRC_CHECK
error, think something with the error handling check. Since rfcomm layer
having problem, PPP layer definitely not working.

The userstack is working fine.


Benham



-----Original Message-----
From: owner-bluetooth-dev@xxxxxxx.com
[mailto:owner-bluetooth-dev@xxxxxxx.com]On Behalf Of sklaw
Sent: Tuesday, December 26, 2000 10:13 AM
To: majordomo@xxxxxxx.com
Subject: [bluetooth-dev] Evaluations of Axis bluetooth_20001031 and
_1115. with null modem


Hi there,

We connected  2 Linux PCs (kernel 2.4.16) with a null modem cable.( with
unmarked // #HCI ...... in btconfig.h to enable HCI emulation)


Tests results as follows:

bluetooth_20001031 : 2 PC  got connection with user mode but not with kernel
mode :

User mode :
Server: btduser -m -i no_hw -e 0
Client:  btduser -m -i no_hw -e 0 --client

After commands menu displayed on screen, key-in:

con 11:22:33:44:55:66 0 1 0

2 PCs connected very well as same message shown on each screen, key in: ppp

After all connection procedure completed, we can ping and telnet anywhere.
That means it works.


But with kernel mode command:

Server: btd -m -i no_hw -e 0
Clinet : btd -m -i no_hw -e 0 --client


After command memu shows, key in :
con 11:22:33:44:55:66 0 1 0


The screen shows handle 0 and then returns to command menu waiting commands.
The 2 PC is not connected. Please advise what we have done incorrect.

Furthermore, /etc/ppp/options.ttyBT0 seems no effect at all and  we have to
use /etc/ppp/options instead with contents to assign IPs.

Then,

we do  the same things with bluetooth_20001115. But it shows handle 0 and
return to command menu under both user mode ( btduser ....) and kernel mode
( btd ....) . The 2 PC got no connection. We also tested rf_conn and got
similar results.

Would someone help and advise what we have done wrong and how we can use
kernel mode and with bluetooth_1115 with null modem.

Thanks a lot in advance.

Best regards,

Paul S. K. Law

sklaw@xxxxxxx.tw


-
To unsubscribe from this list: send the line "unsubscribe bluetooth-dev" in
the body of a message to majordomo@xxxxxxx.com


_________________________________________________________
Do You Yahoo!?
Get your free @xxxxxxx.com">http://mail.yahoo.com

-
To unsubscribe from this list: send the line "unsubscribe bluetooth-dev" in
the body of a message to majordomo@xxxxxxx.com