[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [bluetooth-dev] Evaluations of Axis bluetooth_20001031 and _1115. with null modem



Hi,
i have tried to use _1115 version to set up connection by Ericsson Starter Kits
in usermode. Same as SKLaw,  I tried ppp and rf_conn and both connections failed
and  return to command menu without CRC_Check error.

~~~~~~~~~~~~~~~~~~~~~~~~~
Client
~~~~~~~~~~~~~~~~~~~~~~~~~
[root@xxxxxxx./btduser -R -r client -u /dev/ttyS0 -s 57600 -i
ericsson
Bluetooth Control Application
-----------------------------
Please reset HW board within 5 seconds
Running as client
Running stack in user mode
Physdev /dev/ttyS0, btdev (not used), speed 57600 baud
Opening dev /dev/ttyS0
Initiating physical driver
Initializing Ericsson HW
Init stack
Initiating read thread
BT SYS: Initialising Bluetooth Stack
BT SYS: Initialising HCI
BT SYS: HCI emulator off
BT SYS: Initialising HCI inbuffers [17000]
BT SYS: Reading buffer sizes in the module...

HW module contains...
10 ACL buffers at 800 bytes
0 SCO buffers at 0 bytes

Ericsson HW revision info:
 Generated: 2000-04-28 15:54
 Comment: CXC 125 244 P9A

BT SYS: Initialising L2CAP
process_return_param: READ_BD_ADDR
BT SYS: Local bd [00:d0:b7:03:31:51]
BT SYS: Initialising RFCOMM
BT SYS: Initialising SDP
Opening socket /tmp/sdp_sock
Socket connected to /tmp/sdp_sock
BT SYS: Initialising TCS
BT SYS: Initialising TEST
BT SYS: Initialising BTMEM [2500 bytes]
Initializing Unplug Test
Setting write_scan_enable in Ericsson module!
Setting baudrate in Ericsson module!
BT SYS: set_ericsson_baudrate: Baudrate set command sent
Open pty.
Initiating pty thread
BT SYS: Ericsson baudrate set
Now entering cmd line mode

Menu
------------------------
  inq (inquiry scan)
  con <xx:xx:xx:xx:xx:xx> <line> <server channel> <profile>
  disc <handle>
  send <nbr bytes> <nbr repeats>
  me <1/0>
  setbd <xx:xx:xx:xx:xx:xx>
  readbd
  reset
  stat
  ecs_entertest <handle> (hex)
  ecs_testctrl <par1,par2,...,par9> (hex)
  ecs_txtest   <par1,par2,...,par11> (hex)
  ecs_testcon <xx:xx:xx:xx:xx:xx> (hex)
  enable_dut
  ppp
  quit

--- Test commands ------
  rf_conn <xx:xx:xx:xx:xx:xx> <server channel>
  rf_send <bytes> <dlci>
  rf_disc <line>
  sdp_conn  <xx:xx:xx:xx:xx:xx> <profile>
  tcs_conn  <xx:xx:xx:xx:xx:xx>

  test_conn  <xx:xx:xx:xx:xx:xx> <psm>
  test_disc
  test_case_reject <xx:xx:xx:xx:xx:xx>
  ping <xx:xx:xx:xx:xx:xx>
  getinfo <xx:xx:xx:xx:xx:xx> <type>

  bb_conn  <xx:xx:xx:xx:xx:xx>
  bb_disc  <hci handle>

  t <testcase>

> readbd
process_return_param: READ_BD_ADDR
Current bd addr : 00:D0:B7:03:31:51
> ping 00:D0:B7:03:31:51
Pinging bd : 00:FFFFFFD0:FFFFFFB7:03:31:51
> BT SYS: ACL link failed, remove connection

> error: command not recognized or wrong syntax

> rf_conn 00:D0:B7:03:31:51 2
Connecting RFCOMM to bd : 00:FFFFFFD0:FFFFFFB7:03:31:51
RFCOMM server channel is 2
> BT SYS: rfcomm_connect_cfm: Connection failed
rfcomm_create_connection ready.
BT SYS: ACL link failed for some reason, remove con object
BT SYS: ACL link failed, remove connection

> error: command not recognized or wrong syntax

> ppp
<<<<<<<<<<<<<<<-------------------------------- hang!!!!!

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Server
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
[root@xxxxxxx./btduser -R -s 57600 -u /dev/ttyS0 -i ericsson
Bluetooth Control Application
-----------------------------
Please reset HW board within 5 seconds
Running as server
Running stack in user mode
Physdev /dev/ttyS0, btdev (not used), speed 57600 baud
Opening dev /dev/ttyS0
Opening server socket /tmp/sdp_sock
SDP Server listens...
Initiating physical driver
Initializing Ericsson HW
Init stack
Initiating read thread
BT SYS: Initialising Bluetooth Stack
BT SYS: Initialising HCI
BT SYS: HCI emulator off
BT SYS: Initialising HCI inbuffers [17000]
BT SYS: Reading buffer sizes in the module...

HW module contains...
10 ACL buffers at 800 bytes
0 SCO buffers at 0 bytes

Ericsson HW revision info:
 Generated: 2000-04-28 15:54
 Comment: CXC 125 244 P9A

BT SYS: Initialising L2CAP
process_return_param: READ_BD_ADDR
BT SYS: Local bd [00:d0:b7:03:31:8b]
BT SYS: Initialising RFCOMM
BT SYS: Initialising SDP
Opening socket /tmp/sdp_sock
Socket connected to /tmp/sdp_sock
BT SYS: Initialising TCS
BT SYS: Initialising TEST
BT SYS: Initialising BTMEM [2500 bytes]
Initializing Unplug Test
Setting write_scan_enable in Ericsson module!
Setting baudrate in Ericsson module!
BT SYS: set_ericsson_baudrate: Baudrate set command sent
Open pty.
Initiating pty thread
BT SYS: Ericsson baudrate set

i could not set up any connections. Any faults with my setting? Can anyone
figure it out? or, is this the stack problem?

Tung
HKUST










sklaw wrote:

> Hi Benham,
>
> Thanks.  Please tell you use real bt or null modem for evaluation.
>
> It seems we got the same findings that user mode works fine but not with
> kernel mode command in both _0814 and 1031 .
>
> For _1115,  we tried ppp and rf_conn and got handle 0 and return to command
> menu without CRC_Check error in both kernel mode and user mode.  Is that
> because you use bt instead of null modem? Please confirm!
>
> If anyone got kernel mode connected, please help! Because according to
> previous email discussion with null modem, kernel mode command  btd -m
> .......  instead of btduser -m ........ commands is used.
>
> Need help urgently! Thanks in advance.
>
> Paul S. K. Law
>
> ----- Original Message -----
> From: Chia Benham <chiabenham@xxxxxxx.com>
> To: <bluetooth-dev@xxxxxxx.com>
> Sent: Thursday, December 28, 2000 3:02 AM
> Subject: RE: [bluetooth-dev] Evaluations of Axis bluetooth_20001031 and
> _1115. with null modem
>
> > I tried with the kernel mode, handle 0 is returned however when i try to
> > test the rfcomm layer by "send 100 10". The debug message give CRC_CHECK
> > error, think something with the error handling check. Since rfcomm layer
> > having problem, PPP layer definitely not working.
> >
> > The userstack is working fine.
> >
> >
> > Benham
> >
> >
> >
> > -----Original Message-----
> > From: owner-bluetooth-dev@xxxxxxx.com
> > [mailto:owner-bluetooth-dev@xxxxxxx.com]On Behalf Of sklaw
> > Sent: Tuesday, December 26, 2000 10:13 AM
> > To: majordomo@xxxxxxx.com
> > Subject: [bluetooth-dev] Evaluations of Axis bluetooth_20001031 and
> > _1115. with null modem
> >
> >
> > Hi there,
> >
> > We connected  2 Linux PCs (kernel 2.4.16) with a null modem cable.( with
> > unmarked // #HCI ...... in btconfig.h to enable HCI emulation)
> >
> >
> > Tests results as follows:
> >
> > bluetooth_20001031 : 2 PC  got connection with user mode but not with
> kernel
> > mode :
> >
> > User mode :
> > Server: btduser -m -i no_hw -e 0
> > Client:  btduser -m -i no_hw -e 0 --client
> >
> > After commands menu displayed on screen, key-in:
> >
> > con 11:22:33:44:55:66 0 1 0
> >
> > 2 PCs connected very well as same message shown on each screen, key in:
> ppp
> >
> > After all connection procedure completed, we can ping and telnet anywhere.
> > That means it works.
> >
> >
> > But with kernel mode command:
> >
> > Server: btd -m -i no_hw -e 0
> > Clinet : btd -m -i no_hw -e 0 --client
> >
> >
> > After command memu shows, key in :
> > con 11:22:33:44:55:66 0 1 0
> >
> >
> > The screen shows handle 0 and then returns to command menu waiting
> commands.
> > The 2 PC is not connected. Please advise what we have done incorrect.
> >
> > Furthermore, /etc/ppp/options.ttyBT0 seems no effect at all and  we have
> to
> > use /etc/ppp/options instead with contents to assign IPs.
> >
> > Then,
> >
> > we do  the same things with bluetooth_20001115. But it shows handle 0 and
> > return to command menu under both user mode ( btduser ....) and kernel
> mode
> > ( btd ....) . The 2 PC got no connection. We also tested rf_conn and got
> > similar results.
> >
> > Would someone help and advise what we have done wrong and how we can use
> > kernel mode and with bluetooth_1115 with null modem.
> >
> > Thanks a lot in advance.
> >
> > Best regards,
> >
> > Paul S. K. Law
> >
> > sklaw@xxxxxxx.tw
> >
> >
> > -
> > To unsubscribe from this list: send the line "unsubscribe bluetooth-dev"
> in
> > the body of a message to majordomo@xxxxxxx.com
> >
> >
> > _________________________________________________________
> > Do You Yahoo!?
> > Get your free @xxxxxxx.com">http://mail.yahoo.com
> >
> > -
> > To unsubscribe from this list: send the line "unsubscribe bluetooth-dev"
> in
> > the body of a message to majordomo@xxxxxxx.com
> >
> ----- Original Message -----
> From: Chia Benham <chiabenham@xxxxxxx.com>
> To: <bluetooth-dev@xxxxxxx.com>
> Sent: Thursday, December 28, 2000 3:02 AM
> Subject: RE: [bluetooth-dev] Evaluations of Axis bluetooth_20001031 and
> _1115. with null modem
>
> > I tried with the kernel mode, handle 0 is returned however when i try to
> > test the rfcomm layer by "send 100 10". The debug message give CRC_CHECK
> > error, think something with the error handling check. Since rfcomm layer
> > having problem, PPP layer definitely not working.
> >
> > The userstack is working fine.
> >
> >
> > Benham
> >
> >
> >
> > -----Original Message-----
> > From: owner-bluetooth-dev@xxxxxxx.com
> > [mailto:owner-bluetooth-dev@xxxxxxx.com]On Behalf Of sklaw
> > Sent: Tuesday, December 26, 2000 10:13 AM
> > To: majordomo@xxxxxxx.com
> > Subject: [bluetooth-dev] Evaluations of Axis bluetooth_20001031 and
> > _1115. with null modem
> >
> >
> > Hi there,
> >
> > We connected  2 Linux PCs (kernel 2.4.16) with a null modem cable.( with
> > unmarked // #HCI ...... in btconfig.h to enable HCI emulation)
> >
> >
> > Tests results as follows:
> >
> > bluetooth_20001031 : 2 PC  got connection with user mode but not with
> kernel
> > mode :
> >
> > User mode :
> > Server: btduser -m -i no_hw -e 0
> > Client:  btduser -m -i no_hw -e 0 --client
> >
> > After commands menu displayed on screen, key-in:
> >
> > con 11:22:33:44:55:66 0 1 0
> >
> > 2 PCs connected very well as same message shown on each screen, key in:
> ppp
> >
> > After all connection procedure completed, we can ping and telnet anywhere.
> > That means it works.
> >
> >
> > But with kernel mode command:
> >
> > Server: btd -m -i no_hw -e 0
> > Clinet : btd -m -i no_hw -e 0 --client
> >
> >
> > After command memu shows, key in :
> > con 11:22:33:44:55:66 0 1 0
> >
> >
> > The screen shows handle 0 and then returns to command menu waiting
> commands.
> > The 2 PC is not connected. Please advise what we have done incorrect.
> >
> > Furthermore, /etc/ppp/options.ttyBT0 seems no effect at all and  we have
> to
> > use /etc/ppp/options instead with contents to assign IPs.
> >
> > Then,
> >
> > we do  the same things with bluetooth_20001115. But it shows handle 0 and
> > return to command menu under both user mode ( btduser ....) and kernel
> mode
> > ( btd ....) . The 2 PC got no connection. We also tested rf_conn and got
> > similar results.
> >
> > Would someone help and advise what we have done wrong and how we can use
> > kernel mode and with bluetooth_1115 with null modem.
> >
> > Thanks a lot in advance.
> >
> > Best regards,
> >
> > Paul S. K. Law
> >
> > sklaw@xxxxxxx.tw
> >
> >
> > -
> > To unsubscribe from this list: send the line "unsubscribe bluetooth-dev"
> in
> > the body of a message to majordomo@xxxxxxx.com
> >
> >
> > _________________________________________________________
> > Do You Yahoo!?
> > Get your free @xxxxxxx.com">http://mail.yahoo.com
> >
> > -
> > To unsubscribe from this list: send the line "unsubscribe bluetooth-dev"
> in
> > the body of a message to majordomo@xxxxxxx.com
> >
>
> -
> To unsubscribe from this list: send the line "unsubscribe bluetooth-dev" in
> the body of a message to majordomo@xxxxxxx.com

-
To unsubscribe from this list: send the line "unsubscribe bluetooth-dev" in
the body of a message to majordomo@xxxxxxx.com