[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [bluetooth-dev] Digianswer commercial PC cards connecting RFCOMM with Axis stack driving other Hardware.





Hello,
can someone please post the sucessful 'rf_conn' dump with debug switch on, so we
can compare the packets exchanged(UI, UIH, PN, etc...) on our respective
platforms. This would be a great help for those trying to debug RFCOMM.

THanks,




"mikael.prodhomme" <mikael.prodhomme@xxxxxxx.fr> on 02/28/2001 10:26:04 AM
                                                              
                                                              
                                                              
 To:      "BT (E-mail)" <bluetooth-dev@xxxxxxx.com>              
                                                              
 cc:      (bcc: Mandana Amiri/Inc/Celestica)                  
                                                              
                                                              
                                                              
 Subject: [bluetooth-dev] Digianswer commercial PC cards      
          connecting RFCOMM with Axis stack driving other     
          Hardware.                                           
                                                              








Hello,
     I have even sent an e-mail concerning this subject but no answer and it is
quite urgent for me.

The problem :

I am using a digianswer PC card (commercial version) on omnibook PC : this is
the master.
I am using CSR HW driven  by an ARM (containing AXIS stack : version should be
something like 20010108) : this is the slave.

I first search for services with the PC on the remote CSR HW. I found audio and
serial :-). That is to say SDP is Ok as well as L2CAP since I established the
SDP connexion !

Then I try to connect to remote COM port (RFCOMM). The L2CAP
connection/configuration is OK, the PC card sends a SABM packet and I answer
with a UA (which is acknowledged). BUT, that's all ! The connection hangs and a
message is displayed on the master Screen (PC) : "failed to open com port..."

I used a protocol analyser to check what was wrong but I did not find anything :
It is exactly the same packets which are exchanged between two digianswer PC
cards and the configuration I have talked about above. the different is that the
RFCOMM connection establishment does not stop just after the UA packets...

Is this an interoperability problem ?
Is there anyone who has tried such a connection ? (commercial product versus
Axis Stack driving other hardware ?).
Do you think Digianswer is not totally "opened" ?

Thanks in advance. Please do not hesitate to contact me would you require any
further information (e.g I can send yoo excell files which includes the packets
exchanged in the two cases...)

Best regards.


MikaŽl Prod'homme <mailto:mikael.prodhomme@xxxxxxx.fr> - Software Engineer
WAVECOM S.A. <http://www.wavecom.fr/>
39 rue du gouverneur general Eboue
92442 ISSY les Moulineaux (FRANCE)
Tel : +33 (0)1 46 29 09 30
Cellular: (+33) 06 13 55 63 54

-
To unsubscribe from this list: send the line "unsubscribe bluetooth-dev" in
the body of a message to majordomo@xxxxxxx.com

att1.eml