[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[bluetooth-dev] problems running in usermode



Hello !

When I start usermode I get the following messages:

Bluetooth Control Application
-----------------------------
Running as server
Running stack in user mode
Physdev /dev/ttyS0, btdev (not used), speed 115200 baud
Init stack
Initiating read thread
BT SYS: Initialising Bluetooth Stack
BT SYS: hci_init, Initialising HCI
BT SYS: *** HCI emulator on ***
BT SYS: hci_init, Initialising HCI inbuffers [800]
BT SYS: hci_init, Reading buffer sizes in the module...
BT SYS: hci_init, Host flow control not enabled
BT SYS: Initialising L2CAP
command_handler, Unknown command ogf:0x4,ocf:0x9
BT SYS: ERROR :Failed to get local BD addr
BT SYS: Initialising RFCOMM
BT SYS: Initialising SDP
BT SYS: sdp_init, Init sdp as server
Opening socket /tmp/sdp_sock
connect client socket: Connection refused
BT SYS: ERROR :Couldn't open socket, sdp will not be used
BT SYS: Initialising TCS
BT SYS: Initialising TEST
BT SYS: Initialising BTMEM [2500 bytes]
Initializing Unplug Test
command_handler, Unknown command ogf:0x3,ocf:0x24
command_handler, Unknown command ogf:0x3,ocf:0x13
hci_write_scan_enable, enable 3
command_handler, Unknown command ogf:0x3,ocf:0x1a
Open pty.
Initiating pty thread
Now entering cmd line mode


But I didnīt have defined HCI_EMULATION in btconfig.h and my modules
are working in properly in kernelmode !! Do I have to switch
some more Hardware defines when I use kernelmode ? Because I donīt 
have Ericsson Modules !!
Can somebody help me please ?

Thanks
Cedric
 

-
To unsubscribe from this list: send the line "unsubscribe bluetooth-dev" in
the body of a message to majordomo@xxxxxxx.com