[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Vs: [bluetooth-dev] Re: Connection Problems...still not working!!!



hi michael...how are you doing?  well that was one quick
response...thanks!

okay let me tell you what i am doing?

well (according to v1.1), i first do an
HCI_CREATE_CONNECTION(bd_addr, packet_type, page_scan_repetition_mode,
page_scan_mode, clock_offset, allow_role_switch), and i receive a
COMMAND_STATUS event packet back with status = 0x00, so its all good

then on the host b side it receives an HCI_CONNECTION_REQUEST event
packet, so i do an HCI_ACCEPT_CONNECTION_REQUEST immediately from the host
b side, and host b receives a COMMAND_STATUS event packet with a status =
0x00, so its all good again...then according to the specification we
should, on both the host a, and host b side receive a CONNECTION_COMPLETE
event, and i do, with status = 0x00, so with all this data i should be
able to send data now via the connection handler returned in the
CONNECTION_COMPETE event...but instead it just hangs when i send the
data...

why???? i really don't know why right now, but my assumption right now is
that something is wrong with my connection handler...what do you think?

how did you get the 12 bits from the 2 bytes of the connection handler,
and you said you can receive ACL packets, how would you know if you can't
send anything????

i am still confused and frustrated here!!!!

:)


--------------------------------------------------------------------
Sami Kibria
Researcher
TRLabs - Winnipeg, Manitoba. CANADA
email: skibria@xxxxxxx.ca
--------------------------------------------------------------------
   __   _
  / /  (_)__  __ ____  __
 / /__/ / _ \/ // /\ \/ /  . . .  t h e   c h o i c e   o f   a
/____/_/_//_/\_,_/ /_/\_\              G N U   g e n e r a t i o n

--------------------------------------------------------------------


-
To unsubscribe from this list: send the line "unsubscribe bluetooth-dev" in
the body of a message to majordomo@xxxxxxx.com