[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [bluetooth-dev] Why i could not complie the opbt20010507?



    If i use the kernel 2.2.14 to complie the 0507 stack, the error messages is couldn't find the head file 'kcomp.h',and then I use the command find -name "kcomp.h", I could not find the head file yet.
>    Can anybody E-mail the file kcomp.h to me or tell me what should I do?
>    thank everybody
>     best regard.


Hello,

I had the same problem with th 2.2.14 kernel version. If I remember well, I
made next modification :

On line 54 of the "bluetooth.c" file, I replace :

#if LINUX_VERSION_CODE < KERNEL_VERSION(2,2,0)

by

#if LINUX_VERSION_CODE < KERNEL_VERSION(2,2,18)


So, the #if is true when 2.2.14, and so it doesn't need kcomp.h any more.


Alain Paschoud

SAMRTDATA SA

-
To unsubscribe from this list: send the line "unsubscribe bluetooth-dev" in
the body of a message to majordomo@xxxxxxx.com