[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [bluetooth-dev] HCI failed to initialize



Hi,

HCI failed to initialize of some reason, it's probably a result of that you can't communicate with you BT-HW and therefore can't set it up correctly. Check your debugmessages when communicating with your module (in btdebug.h, switch on all HCI-debug) and make sure you got response on all commands sent. If you are using the stack with no BT-HW, don't forget to switch on the HCI_EMULATOR (btconfig.h). If it still doesn't work you must provide more debug outputs as I can't say exactly what is wrong from the information provided in your mail.

Best Regards
Anders Johansson

> -----Original Message-----
> From: siumama great [mailto:siumama2000@xxxxxxx.com]
> Sent: Monday, October 15, 2001 12:23 PM
> To: bluetooth-dev@xxxxxxx.com
> Subject: [bluetooth-dev] HCI failed to initialize
> 
> 
> HI,
>     Does anyone face the same problem before? when i 
> initialize the bti, it 
> returns errors "init_failed_exit1" "init_failed_exit0" and 
> "BT SYS: ERROR: 
> HCL failed to initialize". Anyone know why??
> 
> 
> _________________________________________________________________
> Get your FREE download of MSN Explorer at 
> http://explorer.msn.com/intl.asp
> 
> -
> To unsubscribe from this list: send the line "unsubscribe 
> bluetooth-dev" in
> the body of a message to majordomo@xxxxxxx.com
> 
-
To unsubscribe from this list: send the line "unsubscribe bluetooth-dev" in
the body of a message to majordomo@xxxxxxx.com