[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[bluetooth-dev] CSR chip no more responding



Hello,

during my tests of the CSR modules, it seems I have "crashed" one chip.

I know this is dangerous to play with pskeys. But I have do it for
changing from BCSP to H4 mode. I have change pskey 0x191 from:
0x01d8 0x0006 0x00FA 0x0014 0x0004 0x0000 0x0004 0x001E 0x0064 0x000A
to:
0x01d8 0x00a8 0x00FA 0x0014 0x0004 0x0000 0x0004 0x001E 0x0064 0x000A

and pskey 0x1f9 from:
0x0001 0x0000 0x0000 0x0000 0x0000 0x0000 0x0000 0x0000 0x0000 0x0000
to:
0x0003 0x0000 0x0000 0x0000 0x0000 0x0000 0x0000 0x0000 0x0000 0x0000

I have controled many times before doing the change (both in the
bt_vendor.c of OpenBT and in the mail
http://www.geocrawler.com/archives/3/11993/2002/3/100/8148714/)

The only difference is I have 115'200 for the speed and not 57'600.

And now, after these changes, the module is no more answering... :-(

Is there a possibility to "reset" the module to some kind of "factory
setting" ? And if yes, how ? I hope this CSR module is not really dead.
At this time, we have a limited number of chip...

Thanks in advance for any help.

		Olivier
-- 
Olivier Bornet                      SMARTDATA SA
Olivier.Bornet@xxxxxxx.ch         Centre du Parc
http://www.smartdata.ch             av. des Prés-Beudin 20
Phone +41-27-723'55'03              CH-1920 Martigny
Fax   +41-27-723'55'19              GPG key ID: C53D9218

Attachment: pgp00017.pgp
Description: PGP signature