[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: RST bit number for DS1302



Try using the hwtestrtc program to set the time,
it wont move until it is set properly.
/Johan


-----Original Message-----
From: Prabhat Avasare <avasare@xxxxxxx.be>
To: dev-etrax@xxxxxxx.com>
Date: Tuesday, December 05, 2000 15:30
Subject: RST bit number for DS1302


>Hi there.
>
>We were trying to use the real-time clock(RTC) on
>axis board, but were not able to succeed. We have
>now checked all the pin numbers to be set in .config
>file - the only one which we are not fully sure is
>CONFIG_DS1302_RSTBIT, which we have put to 27 as per
>the documentation in Configure.help. This bit is
>connected to S110 pin of processor as per schematics.
>Is this value 27 correct? If yes, what else could be
>a possible mistake? When we check the RTC time on
>/proc/rtc, it always stays the same --
>
>28# cat /proc/rtc
>rtc_time        : 00:00:80
>rtc_date        : 2000-01-01
>
>We are using Axis 2400 camera server board as a
>development board. I am attaching my .config file below.
>
>-- prabhat
>ps .config file
>#
># Automatically generated make config: don't edit
>#
>
>#
># Code maturity level options
>#
># CONFIG_EXPERIMENTAL is not set
>
>#
># General setup
>#
>CONFIG_NET=y
># CONFIG_SYSVIPC is not set
>CONFIG_BINFMT_AOUT_CRIS_FLAT=y
>CONFIG_SHARE_SHLIB_CORE=y
># CONFIG_KGDB is not set
># CONFIG_ETRAX_WATCHDOG is not set
>CONFIG_USE_SERIAL_CONSOLE=y
># CONFIG_KERNEL_IFCONFIG is not set
>
>#
># Hardware setup
>#
># CONFIG_ETRAX4 is not set
># CONFIG_SVINTO1 is not set
>CONFIG_SVINTO2=y
># CONFIG_SVINTO_SIM is not set
>ETRAX_DRAM_BASE=40000000
>ETRAX_DRAM_SIZE=16
># CONFIG_ETRAX_PA_LEDS is not set
># CONFIG_ETRAX_PB_LEDS is not set
># CONFIG_ETRAX_90000000_LEDS is not set
>CONFIG_ETRAX_NO_LEDS=y
># CONFIG_DEBUG_PORT0 is not set
>CONFIG_DEBUG_PORT1=y
># CONFIG_DEBUG_PORT2 is not set
># CONFIG_DEBUG_PORT3 is not set
># CONFIG_DEBUG_PORT_NULL is not set
># CONFIG_RESCUE_SER0 is not set
>CONFIG_RESCUE_SER1=y
># CONFIG_RESCUE_SER2 is not set
># CONFIG_RESCUE_SER3 is not set
>DEF_R_WAITSTATES=95f8
>DEF_R_BUS_CONFIG=104
>DEF_R_DRAM_CONFIG=1a800060
>DEF_R_DRAM_TIMING=5611
>DEF_R_PORT_PA_DIR=0d
>DEF_R_PORT_PA_DATA=00
>DEF_R_PORT_PB_CONFIG=00
>DEF_R_PORT_PB_DIR=1b
>DEF_R_PORT_PB_DATA=ff
>
>#
># Floppy, IDE, and other block devices
>#
># CONFIG_BLK_DEV_ETRAXIDE is not set
>
>#
># Additional Block Devices
>#
># CONFIG_BLK_DEV_LOOP is not set
># CONFIG_BLK_DEV_MD is not set
>CONFIG_BLK_DEV_RAM=y
># CONFIG_BLK_DEV_INITRD is not set
>CONFIG_BLK_DEV_KROM=y
>CONFIG_BLK_DEV_FLASH=y
># CONFIG_BLK_DEV_HD is not set
>
>#
># Networking options
>#
># CONFIG_FIREWALL is not set
># CONFIG_NET_ALIAS is not set
>CONFIG_INET=y
>
>#
># IP setting by ping
>#
>CONFIG_PING_IPSET_ENABLED=y
>CONFIG_PING_IPSET_TIME_SEC=1800
>CONFIG_PING_IPSET_LENGTH=0
>CONFIG_PING_IPSET_DONT_USE_PARHAND=y
>
>#
>#  
>#
>CONFIG_IP_FORWARD=y
>CONFIG_IP_MULTICAST=y
># CONFIG_SYN_COOKIES is not set
># CONFIG_IP_ACCT is not set
># CONFIG_IP_ROUTER is not set
># CONFIG_NET_IPIP is not set
>
>#
># (it is safe to leave these untouched)
>#
># CONFIG_INET_PCTCP is not set
># CONFIG_INET_RARP is not set
># CONFIG_NO_PATH_MTU_DISCOVERY is not set
>CONFIG_IP_NOSR=y
>CONFIG_SKB_LARGE=y
>
>#
>#  
>#
># CONFIG_IPX is not set
># CONFIG_ATALK is not set
># CONFIG_AX25 is not set
># CONFIG_NETLINK is not set
>CONFIG_IPSEC=y
>
>#
># IPSec options (FreeS/WAN)
>#
>CONFIG_IPSEC_IPIP=y
># CONFIG_IPSEC_ICMP is not set
># CONFIG_IPSEC_NO_EROUTE_PASS is not set
>CONFIG_IPSEC_AH=y
>CONFIG_IPSEC_AUTH_HMAC_MD5=y
>CONFIG_IPSEC_AUTH_HMAC_SHA1=y
>CONFIG_IPSEC_ESP=y
>CONFIG_IPSEC_ENC_3DES=y
>DEBUG_IPSEC=y
>
>#
># SCSI support
>#
># CONFIG_SCSI is not set
>
>#
># Network device support
>#
>CONFIG_NETDEVICES=y
># CONFIG_DUMMY is not set
># CONFIG_EQUALIZER is not set
># CONFIG_PLIP is not set
># CONFIG_PPP is not set
># CONFIG_SLIP is not set
>CONFIG_NET_ETHERNET=y
>CONFIG_ETRAX_ETHERNET=y
># CONFIG_ETRAX_ETHERNET_LPSLAVE is not set
># CONFIG_SIMULATOR_ETHERNET is not set
>
>#
># ISDN subsystem
>#
># CONFIG_ISDN is not set
>
>#
># CD-ROM drivers (not for SCSI or IDE/ATAPI drives)
>#
># CONFIG_CD_NO_IDESCSI is not set
>
>#
># Filesystems
>#
># CONFIG_QUOTA is not set
># CONFIG_MINIX_FS is not set
># CONFIG_EXT_FS is not set
>CONFIG_EXT2_FS=y
># CONFIG_XIA_FS is not set
>CONFIG_JFFS_FS=y
># CONFIG_JFFS_FS_VERBOSE is not set
>CONFIG_JFFS_PROC_FS=y
># CONFIG_NLS is not set
>CONFIG_PROC_FS=y
>CONFIG_NFS_FS=y
># CONFIG_ROOT_NFS is not set
># CONFIG_SMB_FS is not set
># CONFIG_HPFS_FS is not set
># CONFIG_SYSV_FS is not set
>CONFIG_ROMFS_FS=y
># CONFIG_UFS_FS is not set
>
>#
># Character devices
>#
>CONFIG_ETRAX100_SERIAL=y
># CONFIG_SERIAL_PROC_ENTRY is not set
># CONFIG_ETRAX100_SERIAL_FLUSH_DMA_FAST is not set
>CONFIG_ETRAX100_SERIAL_RX_TIMEOUT_TICKS=5
>
>#
>#   Ports 0 and 1 are always enabled
>#
># CONFIG_ETRAX100_SER0_DTR_RI_DSR_CD_ON_PB is not set
>CONFIG_ETRAX100_SER1_DTR_RI_DSR_CD_ON_PB=y
>CONFIG_ETRAX100_SER1_DTR_ON_PB_BIT=4
>CONFIG_ETRAX100_SER1_RI_ON_PB_BIT=5
>CONFIG_ETRAX100_SER1_DSR_ON_PB_BIT=6
>CONFIG_ETRAX100_SER1_CD_ON_PB_BIT=7
># CONFIG_ETRAX100_SERIAL_PORT2 is not set
># CONFIG_ETRAX100_SERIAL_PORT3 is not set
># CONFIG_RS485 is not set
># CONFIG_BLUETOOTH is not set
>CONFIG_ETRAX100_I2C_MANUALLY=y
>CONFIG_I2C_EEPROM=y
># CONFIG_I2C_EEPROM_PROBE is not set
>CONFIG_I2C_EEPROM_2KB=y
># CONFIG_I2C_EEPROM_8KB is not set
># CONFIG_I2C_EEPROM_16KB is not set
># CONFIG_JULIETTE is not set
>CONFIG_ETRAX100_I2C=y
>CONFIG_CHR_DEV_FLASH=y
># CONFIG_ETRAX100_IRCONTROL is not set
># CONFIG_ETRAX100_SYNCSER is not set
>CONFIG_ETRAX_GPIO=y
>CONFIG_ETRAX_PA_BUTTON_BITMASK=02
>CONFIG_PA_CHANGEABLE_DIR=00
>CONFIG_PA_CHANGEABLE_BITS=ff
>CONFIG_PB_CHANGEABLE_DIR=05
>CONFIG_PB_CHANGEABLE_BITS=ff
># CONFIG_ETRAX100_PARALLEL is not set
># CONFIG_ETRAX100_PARDATA is not set
># CONFIG_WATCHDOG is not set
>CONFIG_DS1302=y
>CONFIG_DS1302_RST_ON_GENERIC_PORT=y
>CONFIG_DS1302_RSTBIT=27
>CONFIG_DS1302_SCLBIT=3
>CONFIG_DS1302_SDABIT=2
># CONFIG_LCD_HD44780 is not set
>CONFIG_IRQ_VIRTEX=y
>
>#
># Sound
>#
># CONFIG_SOUND is not set
>
>#
># Kernel hacking
>#
># CONFIG_PROFILE is not set
>
>