[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: CGI-scripts for BOA under 2.4 kernel (LX-board)



> I am trying to port my old application (elinux) to the new 2.4-kernel.
> 
> I have just found a problem with my CGI-scripts for BOA. They are not working!
> 
> The problems occurs when i am sending parameters to them (which is kind of the idea...).
> The error code for that try is: "Segmentation fault"
> 
> I have also tried your "editcgi.cgi". Same errorcode...
> 
> 
> Have i done something wrong when installing 2.4-kernel or isn't your CGI-parser working anymore??

I've just built devboard_lx R1_0_0 from scratch and I don't get any segfaults using editcgi.cgi. Try using gdb to find where the segfault occurs. If it does not segfault when you run it manually (from the command line, not from boa) you can add a sleep() at the beginning of the cgi-script so that you get a chance to attach from gdb using the process id of the cgi-script.

Best regards
/Jonas