[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Status LED



When I make a flashitall, the following happens:

./flashitall
* size is 4194328 0x00400018
Using internal boot loader: DBG2 - Debug on ser2.
Starting boot...
We're doing a flash write, this may take up to a few minutes...

and the boot loader program hangs and the LED never lights.

I used the AMD flash AM29DL323DT (32 Megabit) which contains two banks with different size (8 and 24). This is a simultaneous operation flash memory. The axis web page
suggests to use the AM29LV320DT which is a boot sector flash memory with only one bank. Is it possible that the flash I used is not compatible?

Best regards

Vincent Lenders


Jonas Holmberg wrote:

> > I changed the Flash on my developer board LX. When I try to
> > flash a new
> > image to the new Flash, nothing happens. The status LED does never
> > light. I am asking myself if the Flash is damaged, or the
> > board itself.
> >
> > My question is : When does the status LED light. The
> > documentation says
> > that the LED will light during processor activation. But in this case,
> > the flash doesn't contain any image. Should then the LED light?
>
> The status LED is turned on by the boot loader, before writing to the flash starts and by the kernel during startup. The LED is turned off later by the ethernet driver.
>
> Do you get any debug output when you try to flash the new flash? Does the boot loader program (flashit, flashitall or boot_linux) terminate or hang?
>
> If you haven't changed anything else (like the way you connect your PC and the board to the network) then the new flash is probably not mounted correctly.
>
> Best regards
> /Jonas