[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Problems getting pppd to work over async devices



Hi there,
 
Been searching through the mailing list to get some help in getting the pppd to work over the async devices (ie. modem on /dev/ttyS0).
With some luck, there was one thread that mentioned the exact problem I have but had no solution to it. Thread was "Problems compiling ppp for linux-2.4".
 
Thread mentions that issueing "pppd /dev/ttyS0 115200 noauth" results nothing. However, issueing "pppd /dev/ttyp0", you see pppd sending out the LCP-req on the console.
 
Following the suggestion made by sebastian, "which is to add debug nodetach" and even nodefaultip (should read noipdefault), I see no extra logging is done via pppd. Thus, I'm back to square one.
 
After long struggle, I can get development board to pick up the modem -> handshake -> login (I'm getting the sash prompt at least). But pppd refuses to send out LCP-req over the serial line.
 
FYI: I'm using kernel-2.4.3 / Cris compiler 1.11 / Devboard_lx 1.0.0.
I have included /dev/ppp as mentioned in the newsgroup. And also, I have enabled ppp from the kernel, plus ppp over async/ppp over sync/ppp vjcomp/ppp deflate.
 
IN SHORT, pppd executes fine, but does not send LCP-req over a serial line, but does send LCP-req over a ttyp0 device.
 
Any thoughts are welcome ...
 
PS.: I'm starting the pppd manually after loging onto the LX over a modem connection (/dev/ttyS0).
 
Cheers,
 
Daniel Ann
Diginics Inc.