[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: Running on developer-board, OK! Running on camera2420, Failed!



> I wrote an application. It's compiled with Linux kernel 2.4 and cris-
> dist-1.13. There is no problem let it run on Developer-Board LX 
> (through both porting image file and ftp into /mnt/flash). Now, I 
> want to make it run on an Axis2420 camera. After ftp it and "chmod", 
> I cannot run it successfully. It told me "No such file or directory" 
> no matter I run "mytest" or "./mytest".
> 
> In the manual of this 2420 camera, I found it's software release is 
> 2.12. 
> 
> Do I need upgrade the firmware in my 2420 camera? If yes, upgrade to 
> which version?

The 2420 is running elinux (i.e. Linux 2.0) and your app is probably built for
Linux 2.4...

> In addition, can I "flashit" the new-generated image file into my 
> 2420 camera and keep up all originally provided functions by the 
> camera?

No, it won't even work at all since it's not the same hardware as the
developer board.

Best regards
/Jonas