[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Serial port ;-)



The driver in 2.4 does not yet handle "breaks" and errors very well
(it's fixed in elinux) so if you have "nasty" hardware that generates
breaks or framing errors on powerup this might happen.
I believe merging of the elinux driver to the 2.4 tree is in progress.

/Johan

----- Original Message -----
From: Szabo, Tamas <Tamas.Szabo@xxxxxxx.com>
To: <dev-etrax@xxxxxxx.com>
Sent: Saturday, October 06, 2001 6:07 PM
Subject: Serial port ;-)


> Hi,
>
> It seems that I does not bother myself about serial port matter.
>
> +12V _      ________
>   0V _...__|        |    ||  ||||  ...
> -12V _              |____||__||||__
>
>            | ~350ms |  |-pwr on string--|
>
> When I power on my connected device, there is a ~350ms transient. After it
I
> can not read from serial port. If I connect the port after the transient
it
> works fine. Unfortunately I must catch the power on string so it is not
> possible to connect before power on.
>
> My port settings:
> opened as O_RDWR O_NOCTTY O_SYNC
> c_cflag= B9600 | CS8 | CLOCAL | CREAD
> c_iflag= IGNPAR | IGNCR
> c_oflag= 0
> c_lflag= 0
>
> With these settings the application works well on PC.
> What meke I wrong?
>
> Thx in advance
> Sza2
>
>
> **********************************************************************
> This email and any files transmitted with it are confidential and
> intended solely for the use of the individual or entity to whom they
> are addressed.
> Sony cannot accept liability for statements made which are clearly
> the sender's own and not made on behalf of Sony.
> (03)
> **********************************************************************
>