[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Problem with install script



Hi,

when I'm following the instructions on how to install the developer board software on my PC I get the following error:
http://developer.axis.com/doc/software/devboard_lx/install-howto.html

>Your gcc-cris is too old! Upgrade to at least cris-dist-1.13"
>You can download it from ,,,

I tried it with 1.14 and 1.13 both didn't work.
I'm running the a 2.2.12 kernel but I have the 2.4.5 available as described in the documentation.

If I comment out the failing line I'm able to complete the software installation.
Should I be concerned about that problem or is it just a bad error message?

Markus



cd axis/devboard_lx
./install

...
...
GCC_CRIS_MAJOR=`gcc-cris --version | cut -d . -f 1`
GCC_CRIS_MINOR=`gcc-cris --version | cut -d . -f 2 | cut -d - -f 1`

if [ "$GCC_CRIS_MAJOR" -lt 2 -o \
     "$GCC_CRIS_MAJOR" -eq 2 -a "$GCC_CRIS_MINOR" -lt 96 ] || \
   ! ( gcc-cris -mlinux -print-file-name=ld.so.1 | grep '/' >/dev/null 2>&1 ); \
   then
        echo "*** Your gcc-cris is too old! Upgrade to at least cris-dist-1.13"
        echo "*** You can download it from"
...
...


This line fails:
----------------
! ( gcc-cris -mlinux -print-file-name=ld.so.1 | grep '/' >/dev/null 2>&1 ); \