[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Problem with install script



> From: Markus Roccaro <markus.roccaro@xxxxxxx.com>
> Date: Sun, 14 Oct 2001 23:46:53 -0700

> when I'm following the instructions on how to install the developer board software on my PC I get the following error:
> http://developer.axis.com/doc/software/devboard_lx/install-howto.html
> 
> >Your gcc-cris is too old! Upgrade to at least cris-dist-1.13"
> >You can download it from ,,,
> 
> I tried it with 1.14 and 1.13 both didn't work.
> I'm running the a 2.2.12 kernel but I have the 2.4.5 available as described in the documentation.
> 
> If I comment out the failing line I'm able to complete the software installation.
> Should I be concerned about that problem or is it just a bad error message?

Of course you should be concerned.
How did you install, using the .i386.rpm or using the tarballs?
If with the tarballs, did you add glibc and the header tarballs?

If you add these three lines just above the first
"too-old"-echo, in install, what does "./install" then say
(before the "too old" message)?

gcc-cris --version
gcc-cris -mlinux -print-file-name=ld.so.1
echo "MAJOR: $GCC_CRIS_MAJOR MINOR: $GCC_CRIS_MINOR"

> This line fails:
> ----------------
> ! ( gcc-cris -mlinux -print-file-name=ld.so.1 | grep '/' >/dev/null 2>&1 ); \

Did it fail with a message (as in: how do you know about the
failure)?

Thanks for taking the time.

brgds, H-P