[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: e2fsprog and fdisk...



Hi,

>So, My conclusion is that ide driver can't support LBA48 mode HDD. 

Seams like a reasonable conclusion. I will check if anyone at 
Axis has tested > 130 GB. I don't think that any changes should
be necessary in the CRIS IDE driver to make LBA48 mode work
but I am not sure,

At what stage does it fail? fdisk, mke2fs or mount? I know
that we have a problem with 2.4.19 with a 60 GB IBM disk
which behaves differently from all other disks we have seen.
With this disk ext2fs can't be mounted (but it works with
2.4.17...). It is on my todo-list to investigate this
problem.

/Mikael
-----Original Message-----
From: Randy Lee(AIo)
To: 'Mikael Starvik'; dev-etrax
Sent: 2003-01-08 08:49
Subject: RE: e2fsprog and fdisk...

I try the code you sent before. It works with IDE 80GB hdd. But it
still does not work with 160GB HDD.
And, e2fsprogs-1.32 I modified works also except some warning messages.
but same symptom with yours.
So, My conclusion is that ide driver can't support LBA48 mode HDD.
My kernel version is 2.4.19.
Any idea?


-----Original Message-----
From: owner-dev-etrax@xxxxxxx.com">mailto:owner-dev-etrax@xxxxxxx.com] On
Behalf Of Mikael Starvik
Sent: Tuesday, January 07, 2003 11:51 PM
To: 'Randy Lee (AIio?) '; dev-etrax
Subject: RE: e2fsprog and fdisk...


It seams like we have made some changes in the configure script and
then generated the Makefile with that. I will send you a complete diff
between the official 1.25 and the tar file I sent you. I have no idea
if this is at all applicable for 1.32. Why don't try the code I sent
you before trying to upgrade?

/Mikael

-----Original Message-----
From: Randy Lee(AIo) [mailto:randylee@xxxxxxx.kr]
Sent: Tuesday, January 07, 2003 3:19 PM
To: 'Mikael Starvik'; dev-etrax
Subject: RE: e2fsprog and fdisk...


Thanks. e2fsprogs you sent is working well.
Currently I have a 16GB HDD.
And My configuration is:
 - Linux kernel 2.4.19
 - e2fsprogs-1.32
 - util-linux-2.11y(fdisk)

[e2fsprogs-1.32]
I modified MCONFIG.in and Makefile.in.
It is compiled well. And looks like working except I get error message
"ext2fs_check_if_mount:......" Actually it does not work. mke2fs looks
like working well. 
But dumpe2fs say "Bad magic number in super block......"
Where else do I have to modify?

Thanks.

-----Original Message-----
From: owner-dev-etrax@xxxxxxx.com">mailto:owner-dev-etrax@xxxxxxx.com] On
Behalf Of Mikael Starvik
Sent: Tuesday, January 07, 2003 7:12 PM
To: 'Randy Lee (AIˢioE?ˢϡ) '; dev-etrax
Cc: Mats Friberg
Subject: RE: e2fsprog and fdisk...


Hi,

Yes, we use e2fsprog and fdisk in Axis products (e.g. the 
Axis 2460 DVR). Normally you only have to do small 
modifications in the Makefile to make an application work
on ETRAX 100LX and so is also the case for e2fsprogs and
fdisk.

I will send you a separate email with the e2fsprogs and
fdisk we usetoday. 

PS. There are also customers who succesfully runs reiserfs. DS

/Mikael

-----Original Message-----
From: owner-dev-etrax@xxxxxxx.com]On">mailto:owner-dev-etrax@xxxxxxx.com]On
Behalf Of Randy Lee(AIio?)
Sent: Monday, January 06, 2003 9:25 AM
To: dev-etrax
Subject: e2fsprog and fdisk...


Does anybody has e2fsprog and fdisk ported to Etrax100LX?

Thanks in advance..