[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Dev board USB problem



Were you able to solve this problem?
I'm getting the same errors as you are.
Thanks,
Dave

Quinton Jansen wrote:
> Hi All,
> 
> I'm trying to add a USB port to my dev board, without much success.
> 
> Below is a debug dump.  When I enable USB port 2 in the kernel, I get this 
> dump, and then the device freezes.
> 
> The only mods to the kernel config that I have made are:
> - Enable lp0 (parallel port)
> - Enable usb2
> - Disable ser3, ser1, and rs485.
> 
> Any ideas would be appreciated.
> 
> Thanks,
> 
> Quinton
> 
> usb-host.c: ETRAX 100LX USB-HCD $Revision: 1.13 $ (c) 2001 Axis 
> Communications AB
> 
>                                                                                                                                                     
> usb.c: new USB bus registered, assigned bus number 1
>                        Product: USB ETRAX 100LX Root Hub
>                                                         SerialNumber: ff
>                                                                         
> hub.c: USB hub found
>                                                                                             
> hub.c: 2 ports detected
>                                                                                                                    
> NET4: Linux TCP/IP 1.0 for NET4.0
>                                                                                                                                                     
> IP Protocols: ICMP, UDP, TCP
>                                                                                                                                                                                 
> kmem_create: Forcing size word alignment - ip_dst_cache
>                                                       IP: routing cache 
> hash table of 1024 buckets, 8Kbytes
>                                                                                                            
> TCP: Hash tables configured (established 1024 bind 1024)
>                                                                                                                                                                    
> NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
>                                      VFS: Mounted root (cramfs filesystem) 
> readonly.
>                                                                                     
> Freeing unused kernel memory: 32k freed
>                                                                                                                            
> hub.c: USB new device connect on bus1/2, assigned device number 2
>            usb-host.c: Undefined error for epid 1
>                                                  usb.c: USB device not 
> accepting new address=2 (error=-71)
>                                                                                                           
> init: starting up.
> hub.c: USB new device connect on bus1/2, assigned device number 3
>                                                                  
> usb-host.c: Undefined error for epid 1
>                                                                                                        
> usb.c: USB device not accepting new address=3 (error=-71)
> 
> 
> 
>