[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: USB Isochronous Problem



Orjan,



Thanks for your response.  Your suggestion didn't quite solve the problem
I'm having.



Here is some more information...



output on debug port...



usb-host.c: Urbs are linked, ignoring.
usb-host.c: Urbs are linked, ignoring.
usb-host.c: Out of synch? Previous frame = 0, current frame = 425
Out of memory.

usb-host.c: error in rx desc->status, epid 2, first urb = 0xc0fe09a0

USB_IN_Desc at 0xc01c09b0
  sw_len  : 0x0400 (1024)
  command : 0x0000
  next    : 0x401c09c0
  buf     : 0x401938a0
  hw_len  : 0x0001 (1)
  status  : 0x02e2

usb-host.c: Completing isoc urb with status -71.
usb-host.c: error in rx desc->status, epid 2, first urb = 0xc0fe08a0

USB_IN_Desc at 0xc01c09d0
  sw_len  : 0x0400 (1024)
  command : 0x0000
  next    : 0x401c09e0
  buf     : 0x401940a0
  hw_len  : 0x0001 (1)
  status  : 0x02e2

usb-host.c: Completing isoc urb with status -71.
usb-host.c: error in rx desc->status, epid 2, first urb = 0xc0fe09a0

------------------------------



I saw the "out of memory" statement so here's the output of /proc/meminfo
...



        total:    used:    free:  shared: buffers:  cached:
Mem:  13459456  9175040  4284416        0   991232  4890624
Swap:        0        0        0
MemTotal:        13144 kB
MemFree:          4184 kB
MemShared:           0 kB
Buffers:           968 kB
Cached:           4776 kB
SwapCached:          0 kB
Active:           2280 kB
Inactive:         4424 kB
HighTotal:           0 kB
HighFree:            0 kB
LowTotal:        13144 kB
LowFree:          4184 kB
SwapTotal:           0 kB
SwapFree:            0 kB


------------------------------





Thanks,

Mike



----- Original Message ----- 
From: "Orjan Friberg" <orjan.friberg@xxxxxxx.com>
To: "Michael T. Francis" <mtfrancis@xxxxxxx.net>
Cc: "dev-etrax" <dev-etrax@xxxxxxx.com>
Sent: Monday, June 30, 2003 10:35 AM
Subject: Re: USB Isochronous Problem


> Michael T. Francis wrote:
> > When using the USB isochronous mode, I keep getting an "Out of Synch"
> > message and then the device locks up.
>
> Try disabling "Product debug-port" under "Hardware setup" ('make
> menuconfig' in the os/linux directory, then 'make kernel' in the
> top-level directory).  You can still get the kernel debug messages by
> reading from /proc/kmsg.
>
> -- 
> Orjan Friberg
> Axis Communications
>
>