[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: PPPD




Hi,

I ran the ./ktest -d eth1 to put the image ( of kernel with PPD) in RAM.
But After that the board doesnot seem to respond to ping/telnet/ftp
commands. Do I need to set the IP address of the board again.

The output I see is
/**********************************************************
Using internal boot loader: INTERNAL_NW - Network boot (default).
Starting boot...


Device ID = 0xc0fa2aed
This bootloader was built by ashutosh on Fri Jul 11 11:47:27 PDT 2003.
Checksum of bootloader is 0x00098b14
Waiting for load info.
Checksum of file is 0x00001ee9
Got load info.
SET_REGISTER
0xb0000000
0x000095f8
SET_REGISTER
0xb0000004
0x00000104
SET_REGISTER
0xb000000c
0x00e03636
SET_REGISTER
0xb0000008
0x8000c002
PAUSE_LOOP
0x00020000
SET_REGISTER
0xb0000008
0x8000c602
SET_REGISTER
0xb0000008
0x8000c002
SET_REGISTER
0x38001f00
0x00000007
SET_REGISTER
0xb0000008
0x8000c402
SET_REGISTER
0xb0000008
0x8000c002
LOOP
0x38001f00
0x38001f5c
SET_REGISTER
0xb0000008
0x8000c402
SET_REGISTER
0xb0000008
0x8000c002
LOOP
0x38001f00
0x38001f5c
SET_REGISTER
0xb0000008
0x8000c402
SET_REGISTER
0xb0000008
0x8000c002
LOOP
0x38001f00
0x38001f5c
SET_REGISTER
0xb0000008
0x8000c402
SET_REGISTER
0xb0000008
0x8000c002
LOOP
0x38001f00
0x38001f5c
SET_REGISTER
0xb0000008
0x8000c402
SET_REGISTER
0xb0000008
0x8000c002
LOOP
0x38001f00
0x38001f5c
SET_REGISTER
0xb0000008
0x8000c402
SET_REGISTER
0xb0000008
0x8000c002
LOOP
0x38001f00
0x38001f5c
SET_REGISTER
0xb0000008
0x8000c402
SET_REGISTER
0xb0000008
0x8000c002
LOOP
0x38001f00
0x38001f5c
SET_REGISTER
0xb0000008
0x8000c402
SET_REGISTER
0xb0000008
0x8000c002
LOOP
0x38001f00
0x38001f5c
SET_REGISTER
0xb0000008
0x8060c202
SET_REGISTER
0xb0000008
0x8000c002
SET_REGISTER
0xb0000008
0x80008002
SET_REGISTER
0xb0000030
0x00001df0
SET_REGISTER
0xb0000038
0x00001ef3
PACKET_INFO
0xc0004000
0x00254000
Checksum of file is 0x10ce5717
JUMP
0xc0004000
END
Exiting with code 0
****************************************************

Any suggestion or idea is welcome.

Ashutosh

-----Original Message-----
From: Orjan Friberg [mailto:orjan.friberg@xxxxxxx.com]
Sent: Friday, July 11, 2003 1:43 AM
To: Ashutosh Verma
Cc: dev-etrax@xxxxxxx.com
Subject: Re: PPPD


Ashutosh Verma wrote:
> Hi,
>
> I am trying to install the pppd package on the Axis 82 board.
>
> I can compile the pakcage axis/devboard_82/apps/ppp-2.4 and get the pppd
> binary target. But when I try to execute it ( after ftping it to
/mnt/flash)
> it gives me an error message saying "libdl.so.2" is missing.
>
> Any suggestion or ideas in this regard is welcome

The normal way is to do a 'make install' in the ppp-2.4 directory, and
then a 'make images' in the top-level directory (followed by a ./ktest
or ./flashit).  The 'make images' part, among other things, determines
which libraries are needed for the applications in the
target/cris-axis-linux-gnu directory.

--
Orjan Friberg
Axis Communications