[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Using ttyS1



Hi,
I need to use /dev/ttyS1 in my devboard_lx and I want to configure
/dev/ttyS1 exactly as /dev/ttyS0.
I don´t need debug ports.

Serial port ttyS1 doesn´t work as ttyS0 because my applications works in
/dev/ttyS0 but not in /dev/ttyS1

Here is part of my kernelconfig:

# CONFIG_ETRAX_DEBUG_PORT0 is not set
# CONFIG_ETRAX_DEBUG_PORT1 is not set
CONFIG_ETRAX_DEBUG_PORT2=y
# CONFIG_ETRAX_DEBUG_PORT3 is not set
# CONFIG_ETRAX_DEBUG_PORT_NULL is not set
# CONFIG_ETRAX_RESCUE_SER0 is not set
# CONFIG_ETRAX_RESCUE_SER1 is not set
CONFIG_ETRAX_RESCUE_SER2=y
# CONFIG_ETRAX_RESCUE_SER3 is not set
CONFIG_ETRAX_SERIAL_PORT0=y
# CONFIG_ETRAX_SER0_DTR_RI_DSR_CD_ON_NONE is not set
# CONFIG_ETRAX_SER0_DTR_RI_DSR_CD_ON_PA is not set
CONFIG_ETRAX_SER0_DTR_RI_DSR_CD_ON_PB=y
# CONFIG_ETRAX_SER0_DTR_RI_DSR_CD_MIXED is not set
CONFIG_ETRAX_SER0_DTR_ON_PA_BIT=-1
CONFIG_ETRAX_SER0_RI_ON_PA_BIT=-1
CONFIG_ETRAX_SER0_DSR_ON_PA_BIT=-1
CONFIG_ETRAX_SER0_CD_ON_PA_BIT=-1
CONFIG_ETRAX_SER0_DTR_ON_PB_BIT=4
CONFIG_ETRAX_SER0_RI_ON_PB_BIT=5
CONFIG_ETRAX_SER0_DSR_ON_PB_BIT=6
CONFIG_ETRAX_SER0_CD_ON_PB_BIT=7
# CONFIG_ETRAX_SERIAL_PORT1 is not set
CONFIG_ETRAX_SERIAL_PORT2=y
# CONFIG_ETRAX_SER2_DTR_RI_DSR_CD_ON_NONE is not set
CONFIG_ETRAX_SER2_DTR_RI_DSR_CD_ON_PA=y
# CONFIG_ETRAX_SER2_DTR_RI_DSR_CD_ON_PB is not set
# CONFIG_ETRAX_SER2_DTR_RI_DSR_CD_MIXED is not set
CONFIG_ETRAX_SER2_DTR_ON_PA_BIT=4
CONFIG_ETRAX_SER2_RI_ON_PA_BIT=5
CONFIG_ETRAX_SER2_DSR_ON_PA_BIT=6
CONFIG_ETRAX_SER2_CD_ON_PA_BIT=7
CONFIG_ETRAX_SER2_DTR_ON_PB_BIT=-1
CONFIG_ETRAX_SER2_RI_ON_PB_BIT=-1
CONFIG_ETRAX_SER2_DSR_ON_PB_BIT=-1
CONFIG_ETRAX_SER2_CD_ON_PB_BIT=-1
CONFIG_ETRAX_SERIAL_PORT3=y
CONFIG_ETRAX_SER3_DTR_RI_DSR_CD_ON_NONE=y
# CONFIG_ETRAX_SER3_DTR_RI_DSR_CD_ON_PA is not set
# CONFIG_ETRAX_SER3_DTR_RI_DSR_CD_ON_PB is not set
# CONFIG_ETRAX_SER3_DTR_RI_DSR_CD_MIXED is not set
CONFIG_ETRAX_SER3_DTR_ON_PA_BIT=-1
CONFIG_ETRAX_SER3_RI_ON_PA_BIT=-1
CONFIG_ETRAX_SER3_DSR_ON_PA_BIT=-1
CONFIG_ETRAX_SER3_CD_ON_PA_BIT=-1
CONFIG_ETRAX_SER3_DTR_ON_PB_BIT=-1
CONFIG_ETRAX_SER3_RI_ON_PB_BIT=-1
CONFIG_ETRAX_SER3_DSR_ON_PB_BIT=-1
CONFIG_ETRAX_SER3_CD_ON_PB_BIT=-1
CONFIG_ETRAX_RS485=y
# CONFIG_ETRAX_RS485_ON_PA is not set
CONFIG_ETRAX_RS485_DISABLE_RECEIVER=y
# CONFIG_ETRAX_SYNCHRONOUS_SERIAL is not set

Somebody knows what is wrong?

Thanks in advanced.

  ____________________________________________
\
/
/   Unai García Amaro                                               \
\   Mondragon Unibertsitatea                          ( o_       /
/   unai.garcia@xxxxxxx.edu     / /\        \
\_____________________________________ V / ____/