[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RV: RE: Network boot




 Hello:

 in http://mhonarc.axis.se/dev-etrax/msg00816.html I found a 
 reply to a post talking about a similar problem.
 It seems the problem was a conflict with some interrupt 
 lines due to the new configuration of the kernel, so when
 you do a ktest the board don't boot properly and you can't
 connect with it.
 You could check kernel configuration. 
 
 Hope this helps. Regards,
 Carlos Ojea
 
  
O> said 
O> On Friday 03 October 2003 12:41, you wrote:
O> > <P>
O> > <BR>
O> > &gt;&gt;...I can't connect using ping or<BR>
O> > &gt;&gt; arp.Am I missing some basic thing?<BR>
O> > <BR>
O> > &gt;Did you solve this problem?<BR>
O> > &gt;Sometimes when I reboot the board or do ktest, the LED 3 
O> >blinks<BR>  &gt;and I can't connect.<BR>  &gt;Then I power down the 
O> >board, wait a little, and power on. If LED 3<BR>  &gt;is 
O> not Blinking I 
O> >can connect to the board, if it blinks I can't.<BR>  <BR>
O> > &gt;Do you know the meaning of that led?<BR>
O> > <BR>
O> > No still I don't have any clue why the ktest made my board 
O> non-bootable.I
O> > don't want to do flashit(I haven't done till now) and 
O> iwthout that I wanna
O> > make things alright(not sure of whether flashit will solve 
O> the probs).What
O> > may be the problem?<BR> <BR>
O> > As u said when I put ON the board all 3 LED glows 
O> altogether(Power LED is
O> > green and other 2 are in orange).Suddenly other 2 will go OFF.Never
O> > blinks.<BR> <BR>
O> > Saying about my knowledge of LEDs.They are Power 
O> LED,Network LED and Radio
O> > LED(think this is the link STATUS LED).Anybody to clarify 
O> about this?<BR>
O> > <BR>
O> > When I do ktest now this the message I get<BR>
O> > <BR>
O> > $ ./ktest<BR>
O> > <BR>
O> > ./ktest<BR>
O> > Using internal boot loader: INTERNAL_NW - Network boot 
O> (default).<BR>
O> > Starting boot...<BR>
O> > <BR>
O> > <BR>
O> > Device ID = 0xc0fa6e0d<BR>
O> > This bootloader was built by root on Mon Aug 18 16:08:32 
O> IST 2003.<BR>
O> > Checksum of bootloader is 0x00098891<BR>
O> > Waiting for load info.<BR>
O> > Checksum of file is 0x00001f09<BR>
O> > Got load info.<BR>
O> > SET_REGISTER<BR>
O> > 0xb0000000<BR>
O> > 0x000095f8<BR>
O> > SET_REGISTER<BR>
O> > 0xb0000004<BR>
O> > 0x00000104<BR>
O> > SET_REGISTER<BR>
O> > 0xb000000c<BR>
O> > 0x00e03636<BR>
O> > SET_REGISTER<BR>
O> > 0xb0000008<BR>
O> > 0x8000c002<BR>
O> > PAUSE_LOOP<BR>
O> > 0x00020000<BR>
O> > SET_REGISTER<BR>
O> > 0xb0000008<BR>
O> > 0x8000c602<BR>
O> > SET_REGISTER<BR>
O> > 0xb0000008<BR>
O> > 0x8000c002<BR>
O> > SET_REGISTER<BR>
O> > 0x38001f00<BR>
O> > 0x00000007<BR>
O> > SET_REGISTER<BR>
O> > 0xb0000008<BR>
O> > 0x8000c402<BR>
O> > SET_REGISTER<BR>
O> > 0xb0000008<BR>
O> > 0x8000c002<BR>
O> > LOOP<BR>
O> > 0x38001f00<BR>
O> > 0x38001f5c<BR>
O> > SET_REGISTER<BR>
O> > 0xb0000008<BR>
O> > 0x8000c402<BR>
O> > SET_REGISTER<BR>
O> > 0xb0000008<BR>
O> > 0x8000c002<BR>
O> > LOOP<BR>
O> > 0x38001f00<BR>
O> > 0x38001f5c<BR>
O> > SET_REGISTER<BR>
O> > 0xb0000008<BR>
O> > 0x8000c402<BR>
O> > SET_REGISTER<BR>
O> > 0xb0000008<BR>
O> > 0x8000c002<BR>
O> > LOOP<BR>
O> > 0x38001f00<BR>
O> > 0x38001f5c<BR>
O> > SET_REGISTER<BR>
O> > 0xb0000008<BR>
O> > 0x8000c402<BR>
O> > SET_REGISTER<BR>
O> > 0xb0000008<BR>
O> > 0x8000c002<BR>
O> > LOOP<BR>
O> > 0x38001f00<BR>
O> > 0x38001f5c<BR>
O> > SET_REGISTER<BR>
O> > 0xb0000008<BR>
O> > 0x8000c402<BR>
O> > SET_REGISTER<BR>
O> > 0xb0000008<BR>
O> > 0x8000c002<BR>
O> > LOOP<BR>
O> > 0x38001f00<BR>
O> > 0x38001f5c<BR>
O> > SET_REGISTER<BR>
O> > 0xb0000008<BR>
O> > 0x8000c402<BR>
O> > SET_REGISTER<BR>
O> > 0xb0000008<BR>
O> > 0x8000c002<BR>
O> > LOOP<BR>
O> > 0x38001f00<BR>
O> > 0x38001f5c<BR>
O> > SET_REGISTER<BR>
O> > 0xb0000008<BR>
O> > 0x8000c402<BR>
O> > SET_REGISTER<BR>
O> > 0xb0000008<BR>
O> > 0x8000c002<BR>
O> > LOOP<BR>
O> > 0x38001f00<BR>
O> > 0x38001f5c<BR>
O> > SET_REGISTER<BR>
O> > 0xb0000008<BR>
O> > 0x8000c402<BR>
O> > SET_REGISTER<BR>
O> > 0xb0000008<BR>
O> > 0x8000c002<BR>
O> > LOOP<BR>
O> > 0x38001f00<BR>
O> > 0x38001f5c<BR>
O> > SET_REGISTER<BR>
O> > 0xb0000008<BR>
O> > 0x8060c202<BR>
O> > SET_REGISTER<BR>
O> > 0xb0000008<BR>
O> > 0x8000c002<BR>
O> > SET_REGISTER<BR>
O> > 0xb0000008<BR>
O> > 0x80008002<BR>
O> > SET_REGISTER<BR>
O> > 0xb0000030<BR>
O> > 0x00001df0<BR>
O> > SET_REGISTER<BR>
O> > 0xb0000038<BR>
O> > 0x00001ef3<BR>
O> > PACKET_INFO<BR>
O> > 0xc0004000<BR>
O> > 0x00256000<BR>
O> > Checksum of file is 0x10d4e886<BR>
O> > JUMP<BR>
O> > 0xc0004000<BR>
O> > END<BR>
O> > Exiting with code 0<BR>
O> > <BR>
O> > While after printing &quot;PACKET_INFO 0xc0004000 
O> 0x00256000 &quot; it
O> > waits for sometime(with all LEDS glowing...don't blink)<BR> <BR>
O> > Hope somebody can figure out where I'm going wrong?<BR>
O> > <BR>
O> > Thanx<BR>
O> > <BR>
O> > -Vishal
O> > </P>
O> > <br><br>
O> > <A target="_blank"
O> > HREF="http://clients.rediff.com/signature/track_sig.asp";><IMG
O> > 
O> SRC="http://ads.rediff.com/RealMedia/ads/adstream_nx.cgi/www.
O> rediffmail.com
O> >/inbox.htm@Bottom" BORDER=0 VSPACE=0 HSPACE=0 HEIGHT=74 
O> WIDTH=496></a>
O> > >>...I can't connect using ping or
O> > >> arp.Am I missing some basic thing?
O> > >
O> > >Did you solve this problem?
O> > >Sometimes when I reboot the board or do ktest, the LED 3 
O> blinks and I 
O> > >can't connect. Then I power down the board, wait a 
O> little, and power 
O> > >on. If LED 3 is not Blinking I can connect to the board, 
O> if it blinks 
O> > >I can't.
O> > >
O> > >Do you know the meaning of that led?
O> >
O> > No still I don't have any clue why the ktest made my board 
O> > non-bootable.I don't want to do flashit(I haven't done 
O> till now) and 
O> > iwthout that I wanna make things alright(not sure of 
O> whether flashit 
O> > will solve the probs).What may be the problem?
O> >
O> > As u said when I put ON the board all 3 LED glows 
O> altogether(Power LED 
O> > is green and other 2 are in orange).Suddenly other 2 will 
O> go OFF.Never 
O> > blinks.
O> >
O> > Saying about my knowledge of LEDs.They are Power 
O> LED,Network LED and 
O> > Radio LED(think this is the link STATUS LED).Anybody to 
O> clarify about 
O> > this?
O> >
O> > When I do ktest now this the message I get
O> >
O> > $ ./ktest
O> >
O> > ./ktest
O> > Using internal boot loader: INTERNAL_NW - Network boot (default). 
O> > Starting boot...
O> >
O> >
O> > Device ID = 0xc0fa6e0d
O> > This bootloader was built by root on Mon Aug 18 16:08:32 IST 2003. 
O> > Checksum of bootloader is 0x00098891 Waiting for load info.
O> > Checksum of file is 0x00001f09
O> > Got load info.
O> > SET_REGISTER
O> > 0xb0000000
O> > 0x000095f8
O> > SET_REGISTER
O> > 0xb0000004
O> > 0x00000104
O> > SET_REGISTER
O> > 0xb000000c
O> > 0x00e03636
O> > SET_REGISTER
O> > 0xb0000008
O> > 0x8000c002
O> > PAUSE_LOOP
O> > 0x00020000
O> > SET_REGISTER
O> > 0xb0000008
O> > 0x8000c602
O> > SET_REGISTER
O> > 0xb0000008
O> > 0x8000c002
O> > SET_REGISTER
O> > 0x38001f00
O> > 0x00000007
O> > SET_REGISTER
O> > 0xb0000008
O> > 0x8000c402
O> > SET_REGISTER
O> > 0xb0000008
O> > 0x8000c002
O> > LOOP
O> > 0x38001f00
O> > 0x38001f5c
O> > SET_REGISTER
O> > 0xb0000008
O> > 0x8000c402
O> > SET_REGISTER
O> > 0xb0000008
O> > 0x8000c002
O> > LOOP
O> > 0x38001f00
O> > 0x38001f5c
O> > SET_REGISTER
O> > 0xb0000008
O> > 0x8000c402
O> > SET_REGISTER
O> > 0xb0000008
O> > 0x8000c002
O> > LOOP
O> > 0x38001f00
O> > 0x38001f5c
O> > SET_REGISTER
O> > 0xb0000008
O> > 0x8000c402
O> > SET_REGISTER
O> > 0xb0000008
O> > 0x8000c002
O> > LOOP
O> > 0x38001f00
O> > 0x38001f5c
O> > SET_REGISTER
O> > 0xb0000008
O> > 0x8000c402
O> > SET_REGISTER
O> > 0xb0000008
O> > 0x8000c002
O> > LOOP
O> > 0x38001f00
O> > 0x38001f5c
O> > SET_REGISTER
O> > 0xb0000008
O> > 0x8000c402
O> > SET_REGISTER
O> > 0xb0000008
O> > 0x8000c002
O> > LOOP
O> > 0x38001f00
O> > 0x38001f5c
O> > SET_REGISTER
O> > 0xb0000008
O> > 0x8000c402
O> > SET_REGISTER
O> > 0xb0000008
O> > 0x8000c002
O> > LOOP
O> > 0x38001f00
O> > 0x38001f5c
O> > SET_REGISTER
O> > 0xb0000008
O> > 0x8000c402
O> > SET_REGISTER
O> > 0xb0000008
O> > 0x8000c002
O> > LOOP
O> > 0x38001f00
O> > 0x38001f5c
O> > SET_REGISTER
O> > 0xb0000008
O> > 0x8060c202
O> > SET_REGISTER
O> > 0xb0000008
O> > 0x8000c002
O> > SET_REGISTER
O> > 0xb0000008
O> > 0x80008002
O> > SET_REGISTER
O> > 0xb0000030
O> > 0x00001df0
O> > SET_REGISTER
O> > 0xb0000038
O> > 0x00001ef3
O> > PACKET_INFO
O> > 0xc0004000
O> > 0x00256000
O> > Checksum of file is 0x10d4e886
O> > JUMP
O> > 0xc0004000
O> > END
O> > Exiting with code 0
O> >
O> > While after printing "PACKET_INFO 0xc0004000 0x00256000 " 
O> it waits for 
O> > sometime(with all LEDS glowing...don't blink)
O> >
O> > Hope somebody can figure out where I'm going wrong?
O> >
O> > Thanx
O> >
O> > -Vishal
O>