[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Library ld.so.1, libcrypt.so.1 ...



See the error from the installation procedure (make tools; make kernel; 
make cris-axis-linux-gnu; make install; make files; make images) :

[root@neptune devboard_lx]# make images
##### Including needed shared library files #####
#### No ld.so.1 in 
/root/axis/devboard_lx/target/cris-axis-linux-gnu/usr/lib 
/root/axis/devboard_lx/target/cris-axis-linux-gnu/lib
make: *** [cramfs.img] Erreur 1

For bypass this trouble I downloaded the /lib directory from the Axis 
Developer Board !
/lib -> /root/axis/devboard/files/lib
and modify the file makespec like this :

files/lib/ld.so.1
files/lib/libcrypt.so.1
files/lib/libc.so.6
files/lib/libnss_dns.so.2
files/lib/libnss_files.so.2
files/lib/libresolv.so.2
files/lib/libutil.so.1

Have you another solution ?

mschapira@xxxxxxx.com a écrit:

>
>
>These files should be in axis/devboard_lx/target/cris-axis-linux-gnu/lib.
>
>The make images target, puts the libraries in question  into the image.
>
>If the libraries in question are not in the image, they can be put into the
>image by editing the Makefile in axis/devboard_lx as follows:
>
>about line 325:
>
>DSOs = find-needed-shlibs.pl $(prefix) ;\
>test -z "$$DSOs" || DSOs= "$$DSOs <name_of_lib" ;\
>.......
>
>Good luck.
>
>Mark Schapira
>
>                                                                                                                                 
>                      Philippe Frossard                                                                                          
>                      <p.frossard@xxxxxxx.com>                               
>                      tecnica.ch>              cc:                                                                               
>                      Sent by:                 Subject:  Library ld.so.1, libcrypt.so.1 ...                                      
>                      owner-dev-etrax@a                                                                                          
>                      xis.com                                                                                                    
>                                                                                                                                 
>                                                                                                                                 
>                      01/29/2004 08:34                                                                                           
>                      AM                                                                                                         
>                                                                                                                                 
>                                                                                                                                 
>I installed devboard_lx_R2_1_0 :
>Why the files ld.so.1, libcrypt.so.1, libc.so.6 ... are not in the
>directory axis/devboard_lx/files/lib ?
>Where to find them ?
>
>  
>