[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

mount nfs



Hi,

We have encountered some problems with the mount -t nfs. We have a MCM 
design which is configured to make
a mount nfs on a PC (under linux).
We use the following script which retries the mount in a loop if not 
succeeded.

#!/bin/sh

mount -t nfs -o nolock $NFS_SERVER:/home/jmarteau/etrax /tmp/mnt -o 
port=2049

while [ $? -ne 0 ]
do
  echo   Mount failed... Retrying...
  sleep 1
  mount -t nfs -o nolock $NFS_SERVER:/home/jmarteau/etrax /tmp/mnt -o 
port=2049
done


export LD_LIBRARY_PATH=/tmp/mnt
cd /tmp/mnt
./TTsensor > $1.log 2 >& 1

exit 0


With only one MCM the mount always succeeds. We make a test with 4 MCMs 
systems which are powered on simultaneously.
Some times one of the MCM did not achieve to mount ...
Any idea ?

Also is it possible to upgrade the mount to have the ability to use the 
smbfs type ?

And third question, I've installed the devbord_lx R2_2_0 release + 
gcc-cris 1.56 and linux 2.4.26. It works successfully.
Now I wonder how should I do to have the same level of release on the MCM.
What should I modify or configure to use the DEVBOARD_LX R2.2.0 on the 
MCM (without external memory).


Thank you for your help

Best regards,

Claude

-- 
____________________________________________
ииииииииииииииииииииииииииииииииииииииииииии
 Claude GIRERD - Service Electronique
ииииииииииииииииииииииииииииииииииииииииииии
 INSTITUT  DE  PHYSIQUE  NUCLEAIRE  DE  LYON
 4, rue Enrico Fermi                   
 69622 Villeurbanne cedex 
ииииииииииииииииииииииииииииииииииииииииииии
 tel: 33 (0)4 72 43 11 05
 fax: 33 (0)4 72 44 80 04
____________________________________________                  
ииииииииииииииииииииииииииииииииииииииииииии