[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

PPPD dialin server



Hi,

I am trying to configure dialin server on the Devloper board (82). I am using mgetty and its AutoPPP feature. when I dial the board, mgetty attends the call and then hands over the line to pppd. pppd starts and then nothing happens... even when the line is hung up by calling party, pppd continues to run.

The options.server file is as follows

-detach
asyncmap 0
auth
crtscts
modem
lock
require-pap
refuse-chap
aa.bb.cc.dd:aa.bb.cc.xx
debug

The output of the mgetty log is as follows

07/29 04:59:38 yS0  select returned 1
07/29 04:59:38 yS0  checking lockfiles, locking the line
07/29 04:59:38 yS0  makelock(ttyS0) called
07/29 04:59:38 yS0  do_makelock: lock='/etc/locks/LCK..ttyS0'
07/29 04:59:38 yS0  lock made
07/29 04:59:38 yS0 wfr: waiting for ``RING''
07/29 04:59:38 yS0  got: [0d][0a]RING[0d]
07/29 04:59:38 yS0  CND: RING
07/29 04:59:38 yS0  wfr: rc=0, drn=0
07/29 04:59:38 yS0 send: ATA[0d]
07/29 04:59:38 yS0 waiting for ``CONNECT''
07/29 04:59:38 yS0  got: ATA[0d]
07/29 04:59:39 yS0  CND: OKATA[0d][0a]CONNECT ** found **
07/29 04:59:57 yS0 send:
07/29 04:59:57 yS0 waiting for ``_''
07/29 04:59:57 yS0  got: 230400[0d]
07/29 04:59:57 yS0  CND: CONNECT 230400
07/29 04:59:57 yS0  CND: found: 230400[0a] ** found **
07/29 04:59:57 yS0  waiting for line to clear (VTIME), read: ~[ff]}#[c0]!}!} } 2}"}&} } } } }%}&}2[a1]bF}'}"}(}"}-}#}&}1}$}&N}3}7}![d9]9[a6]V([da]EV[a0][81]:[b9]V_[c3]}-} } } } [a6]T~
07/29 04:59:57 yS0  looking for utmp entry... (my PID: 270)
07/29 04:59:58 yS0  tio_set_flow_control( HARD )
07/29 04:59:58 yS0  print welcome banner (/etc/issue)
07/29 04:59:58 yS0  getlogname (AUTO_PPP), read:~[ff]}#[c0]!
07/29 04:59:59 yS0  input finished with '\r', setting ICRNL ONLCR
07/29 04:59:59 yS0  tio_get_rs232_lines: status: RTS CTS DSR DTR DCD RI
07/29 04:59:59 yS0  login: use login config file /mnt/flash/mgetty/login.config
07/29 04:59:59 yS0  match: user='/AutoPPP/', key='/AutoPPP/'*** hit!
07/29 04:59:59 yS0  login: utmp entry: /AutoPPP/
07/29 04:59:59 yS0  looking for utmp entry... (my PID: 270)
07/29 04:59:59 yS0  calling login: cmd='/etc/ppp/pppd', argv[]='pppd file /etc/ppp/options.server'
07/29 04:59:59 yS0  setenv: 'CALLER_ID=none'
07/29 04:59:59 yS0  setenv: 'CONNECT=230400'
07/29 04:59:59 yS0  setenv: 'DEVICE=ttyS0'
07/29 04:59:59 ##### data dev=ttyS0, pid=270, caller='none', conn='230400', name='', cmd='/etc/ppp/pppd', user='/AutoPPP/'

And the pppd log (/var/log/messages/) is

Jul 29 04:59:59 AxisProduct pppd[270]: pppd 2.4.2b1 started by root, uid 0

After this point nothing happens.

ps -a | grep pppd returns

291 ttyS0  root    1464  S  pppd file /etc/ppp/options.server

I have got a small website already developed for the developer board. without the pppd dialin working, I cannot proceed.

I also checked the archive and found one post with exactly same problem that i am facing. unfortunately that post did not have any reply.

Hoping that this post gets some reply :)

Thanks in advance,

Alok.