[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Gphoto2 using pkg-config during configure libgphoto2 notrecognized



Hello,

I'm getting closer to being able to get gphoto2 to compile for Axis 82.
However the ligbphoto2 libraries that you all helped me build are not
being recognized by the configure. I think it is because the configure
finds pkg-config (for my host) and tries to use it. The line that fails
is the one where it says -lgphoto2, which I've seen before as standard
notation for using a library. I just do not know how to get -lgphoto2 to
be recognized as the one I've compiled for the Axis. I guess since
libgphoto did not come with the dev kit it needs to be added somewhere.
Any hints as to where? Plus, how can I get it to quit using
pkg-config... or is there an equivalent for the Axis I can point it
to... Also, GP_CFLAGS is incorrect... Basically I think it's finding the
libgphoto2 libs built for my host. Thanks for any tips
-Nate

[snip]
configure:7259: checking GP_CFLAGS
configure:7262: result: -I/usr/include/gphoto2
configure:7265: checking GP_LIBS
configure:7268: result: -lgphoto2 -lm
configure:7296: checking for gp_library_version in -lgphoto2
configure:7327: cris-axis-linux-gnu-gcc -o conftest -g -O2   conftest.c
-lgphoto2 -lgphoto2 -lm    >&5
/usr/local/cris/lib/gcc-lib/cris-axis-linux-gnu/3.2.1/../../../../cris-axis-linux-gnu/bin/ld:
cannot find -lgphoto2
collect2: ld returned 1 exit status
configure:7330: $? = 1
configure: failed program was:
| #line 7303 "configure"
[snip]