[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: I need two files: ld-2.3.2.so and libusb-0.1.so.4.3.0



> -----Original Message-----
> From: owner-dev-etrax@xxxxxxx.com 
> [mailto:owner-dev-etrax@xxxxxxx.com] On Behalf Of "Daniel Würfel"
> Sent: 12 August 2004 14:36
> To: dev-etrax
> Subject: I need two files: ld-2.3.2.so and libusb-0.1.so.4.3.0
> 
> Hi,
> 
> I have a Devboard82 and use kernel 2.4.22 and 2.4.26. 
> Cris-Compiler R1.-56. 
> These 2 files are missing in my lib-directory and I don't 
> know why. So I am not able to create an image.
> Do you have these files in yourt directory? Can you send it to me?
> Thanks in advance,
> Daniel Würfel

Since the version of glibc that is included with
the CRIS compiler you use is 2.2.3, the reference
to ld-2.3.2.so indicates that you have something
linked with some other glibc than the one for CRIS...
You can find out what program/library it is by doing

	cd target/cris-axis-linux-gnu
	readelf -h bin/* sbin/* lib/* | grep 'File\|Machine'

and then look for a line which does not mention Axis
on the Machine line.

As for libusb, you would need to get that from
http://libusb.sourceforge.net/ and compile it for CRIS.

//Peter