[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: BOA web server docs




Unfortunately, the  boa.org  web site documentation is rather sketchy (I
had looked there before).  There are some directives in the 241S/Q which
are not documented at all, and there are no details on how to use the
CGI-related directives.  Too bad there are no examples for each directive
in their docs.

Sourceforge didn't turn up anything either, at least nothing related to my
current problem.

I find it odd that the boa server is issuing "Error-404" when the CGI is
clearly there, in an accessible path which is also "ScriptAliased" and
which does have execute permissions set.

It's quite likely I'm doing something stupid :-)  I have written tons of
CGI shellscripts over the years (under Apache) and have never had a
problem like this.  As I mentioned earlier, it works fine in a 2130, 2411
or 83.

Here is one little test script that I can run manually but which elicits
"Error-404" when I try to access it via its URL:

--------------------------------------

#!/bin/sh

echo -e "Content-Type: text/html\n"     # Must have extra newline

cat <<EOF20
<HTML>
  <HEAD>
    <TITLE>Test Page from Camera</TITLE>
  </HEAD>

  <BODY BGCOLOR="#b1cbca">
    <BLOCKQUOTE>
      <FONT FACE="Arial, Helvetica" SIZE="3">
      <BR><BR><B><U>Camera Test</U></B><BR><BR>
      You have successfully accessed the camera !
      <BR><BR></FONT>
      <FONT FACE="Arial, Helvetica" SIZE="2">
      From the camera's perspective, your IP address<BR>
      appears to be: &nbsp;</FONT>
      <TT>
EOF20

echo $REMOTE_ADDR

cat <<EOF40
      </TT><BR><BR>
      <FONT FACE="Arial, Helvetica" SIZE="1">
      | access_test v1.1 |</FONT><BR>
    </BLOCKQUOTE>
  </BODY>
</HTML>
EOF40

--------------------------------------


Head-scratching continues ... many thanks for the replies so far!

Chuck


-----Original Message-----
From: owner-dev-etrax@xxxxxxx.com]On">mailto:owner-dev-etrax@xxxxxxx.com]On
Behalf Of Mark Richards
Sent: Tuesday, August 17, 2004 12:54 PM
To: chuckm@xxxxxxx.com; 'Etrax Developers'
Subject: RE: BOA web server docs


> A quick question to the members of the list ... I'm having
> great difficulty trying to locate an up-to-date configuration
> guide for the BOA web server.

BOA web server page:
http://www.boa.org/

boa.conf directives:
http://www.boa.org/documentation/boa-2.html#ss2.3

BOA project (forums) on sourceforge:
https://sourceforge.net/forum/?group_id=78
There is some mention of a rights issue with CGI.

This message may also be of some interest:
https://sourceforge.net/forum/message.php?msg_id=2639377

Google:
www.google.com


Mark Richards



> -----Original Message-----
> From: owner-dev-etrax@xxxxxxx.com
> [mailto:owner-dev-etrax@xxxxxxx.com] On Behalf Of chuckm@xxxxxxx.com
> Sent: Tuesday, August 17, 2004 14:34
> To: Etrax Developers
> Subject: BOA web server docs
>
>
>
> A quick question to the members of the list ... I'm having
> great difficulty trying to locate an up-to-date configuration
> guide for the BOA web server.  I notice a distinct change in > boa.conf
directives between 2130/2411/Dev83 implementations
> and the newer 241S/Q and 205. Documentation at boa.org is
> pretty sparse :-)
>
> If anyone can point me to recent, better boa.conf
> documentation it would be greatly appreciated.  My current
> problem relates to getting "error 404" when trying to execute
> CGIs in a 241 even though the script executes as expected if
> invoked manually.
>
> My apologies if this is not an appropriate question for this list.
>
> Chuck
>