[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [gphoto-devel] cross-compiling for Axis 82




Ok, thanks for your reply. Turns out strace has not been ported for the
Axis yet. But they told me to do 'LD_DEBUG=all gphoto2' which spits out
thousands of lines of information. I went through and found these lines
that mention Error. Do they mean anything to you? All of these libs
exist where they are expected, so I do not see what is wrong.

04480:  symbol=__libc_write;  lookup in file=gphoto2
04480:  symbol=__libc_write;  lookup in file=/lib/libpthread.so.0
04480:  symbol=__libc_write;  lookup in file=/usr/lib/libgphoto2.so.2
04480:  symbol=__libc_write;  lookup in file=/lib/libm.so.6
04480:  symbol=__libc_write;  lookup in file=/lib/libc.so.6
04480:  binding file /lib/libpthread.so.0 to /lib/libc.so.6: normal
symbol `__libc_write' [GLIBC_2.2]
*** Error (-4: 'Error loading a library') ***

04480:  symbol=__fxstat64;  lookup in file=gphoto2
04480:  symbol=__fxstat64;  lookup in file=/lib/libpthread.so.0
04480:  symbol=__fxstat64;  lookup in file=/usr/lib/libgphoto2.so.2
04480:  symbol=__fxstat64;  lookup in file=/lib/libm.so.6
04480:  symbol=__fxstat64;  lookup in file=/lib/libc.so.6
04480:  binding file /lib/libc.so.6 to /lib/libc.so.6: normal symbol
`__fxstat64' [GLIBC_2.2]

> > 
> > First, to check what gphoto2 wants ... Try "strace gphoto2" to
> > see where it fails to open libraries.
> > 
> > The prefix is migrated into the lookup path of libgphoto2, so it 
> > shouldfind the camera libraries.
> > 
> 
> Unfortunately, I can't find an strace for the Axis on my host or on 
> theAxis itself. Any other recommendations for how to resolve:
> 
> > [root@AxisProduct /]4113# gphoto2
> > *** Error (-4: 'Error loading a library') ***
> > For debugging messages, please use the --debug option.
> > <snip>
>