[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

using jffs as root filesystem



I changed somethings in our code to setup jffs/mtd as the
root filesystem/dev for our system.  I created a JFFS image
using mkfs.jffs and burned it into flash and then let 'er
rip.

Here is a snippet of the startup:

=====
JFFS: Trying to mount device 1f:03.
JFFS: Successfully mounted device 1f:03.
VFS: Mounted root (jffs filesystem) readonly.
Freeing unused kernel memory: 16k init
  f->size: 0
Warning: unable to open an initial console.
jffs_follow_link(): dentry = 0xc17973e0, inode = 0xc1799980, flag =
0x00000001
jffs_follow_link:   Leaving...
jffs_follow_link(): dentry = 0xc1797660, inode = 0xc1799540, flag =
0x00000001
jffs_follow_link:   Leaving...
jffs_follow_link(): dentry = 0xc1797760, inode = 0xc1799320, flag =
0x00000001
jffs_follow_link:   Leaving...
  f->size: 0
jffs_follow_link(): dentry = 0xc15f71c0, inode = 0xc1798550, flag =
0x00000001
jffs_follow_link:   Leaving...
jffs_follow_link(): dentry = 0xc17973e0, inode = 0xc1799980, flag =
0x00000001
jffs_follow_link:   Leaving...

  <jffs_follow_link repeated over and over>

==========

This "jffs_follow_link" part is repeated without end and the system
never gets beyond this.  

Could someone suggest a possible reason for this?  Or has someone
else experienced this problem?

Thanks for any help,
   -- kelly


_______________________________________________________
Do You Yahoo!?
Get your free @xxxxxxx.ca">http://mail.yahoo.ca