[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: Hard links in JFFS
On Thu, 11 Jan 2001, David Woodhouse wrote:
> We're also likely to want 'snapshot' nodes at some point in the not too
> distant future. We could work round it all by keeping 'snapshot' and
> 'dirent' information as data inside a special inode, but I think it's
> cleaner just to have different types of nodes.
Yes. I prefer any number of different nodes to some special files
> > > __u32 version;
> > Does anyone have a better name for 'version' BTW? 'version' isn't
> > the best word IMO.
> I used 'version' to be consistent with the usage in the data nodes. It
> confused me to start with, but I'm used to it now :)
:) I remember that you had... concerns about the name some time
ago. :) I think we could help people a lot if we changed the name.
Better names are for instance 'sequence', 'sequence_number', or
> > > Perhaps we could split the ugid and permission information off too, but
> > > I don't think we'll gain too much from that.
> > The uid/gid information is associated with the (raw) inode and the
> > hard links (dirents) that refer to this inode should all have the
> > same permissions.
> I meant into a third type of node, so we don't write out ugid and perms
> with every data node written. But I don't think it's worth it.
Okay. I understand. No, I think the ugid and permissions should
stick to the inode and not be split into extra data structures.
To unsubscribe from this list: send the line "unsubscribe jffs-dev" in
the body of a message to email@example.com