[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: 101% in use?



> On Tue, 16 Jan 2001 mark.langsdorf@xxxxxxx.com wrote:
> 
> > I've finally gotten my flash system 95% working, and now I'm
> > performing some stress tests to make sure that everything is
> > good.
> 
> At last :) Good. Have you solved the random oops on write 
> cycles to the ioremapped flash addresses, then?

	Yes, it looks like it was a combination of the code to
calculate offset addresses in cfi_cmdset_0002.c being totally
hosed, and the terrible habit of writing 0xff to non 0xff flash
bytes.  (Both problems have already been fixed in the mainline
code, at about the same time I fixed them in my code base.
Sigh...)

> > The partition size is 14.5 megs, give or take a bit, and
> > I have a very large directly (around 2.7 megs) that I'm
> > repeatedly copying onto the disk and deleting.  At one
> > point, I got my italicization (according to df) up to 
> > 101%, with a negative number of free blocks.  Is this bad?
> 
> I wouldn't worry too much about the results of df. We 
> basically make stuff up in jffs_statfs(). It's only if the
> internal filesystem code _really_ thinks there are negative
> amounts of free space that I'd start to
> wet myself. And I don't think that's the case.

	Okay, that's what I figured, but I wanted to be sure.

-Mark Langsdorf
AMD, Inc.


To unsubscribe from this list: send the line "unsubscribe jffs-dev" in
the body of a message to majordomo@xxxxxxx.com