[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Linux 2.4.2 + mtd-snapshot-20010328 doesn't compile with modules enabled




Em 2001.03.30 17:15:56 -0300 Marcio Koch escreveu:
> I'm trying to compile linux 2.4.2 with patch from mtd-snapshot-20010328
> and
> modules enabled, exactly like in the MTD-JFFS-HOWTO.
> 
> But I aways get this error:
> 
> [cut]
> 
> make[1]: Entrando no diretório `/usr/local/src/linux-2.4.2/arch/ppc/8xx_io'
> make all_targets
> make[2]: Entrando no diretório `/usr/local/src/linux-2.4.2/arch/ppc/8xx_io'
> /opt/hardhat/devkit/ppc/8xx/bin/ppc_8xx-gcc -D__KERNEL__
> -I/usr/local/src/linux-2.4.2/include -Wall -Wstrict-prototypes -O2
> -fomit-frame-pointer -fno-strict-aliasing -D__powerpc__ -fsigned-char
> -msoft-float -pipe -ffixed-r2 -Wno-uninitialized -mmultiple -mstring
> -mcpu=860 -I../8xx_io    -c -o commproc.o commproc.c
> /opt/hardhat/devkit/ppc/8xx/bin/ppc_8xx-gcc -D__KERNEL__
> -I/usr/local/src/linux-2.4.2/include -Wall -Wstrict-prototypes -O2
> -fomit-frame-pointer -fno-strict-aliasing -D__powerpc__ -fsigned-char
> -msoft-float -pipe -ffixed-r2 -Wno-uninitialized -mmultiple -mstring
> -mcpu=860 -I../8xx_io    -c -o uart.o uart.c
> uart.c: In function `serial_console_setup':
> uart.c:2961: warning: zero-length format string
> /opt/hardhat/devkit/ppc/8xx/bin/ppc_8xx-gcc -D__KERNEL__
> -I/usr/local/src/linux-2.4.2/include -Wall -Wstrict-prototypes -O2
> -fomit-frame-pointer -fno-strict-aliasing -D__powerpc__ -fsigned-char
> -msoft-float -pipe -ffixed-r2 -Wno-uninitialized -mmultiple -mstring
> -mcpu=860 -I../8xx_io    -c -o enet.o enet.c
> rm -f 8xx_io.o
> /opt/hardhat/devkit/ppc/8xx/bin/ppc_8xx-ld  -r -o 8xx_io.o commproc.o
> uart.o enet.o
> make[2]: Saindo do diretório `/usr/local/src/linux-2.4.2/arch/ppc/8xx_io'
> make[1]: Saindo do diretório `/usr/local/src/linux-2.4.2/arch/ppc/8xx_io'
> /opt/hardhat/devkit/ppc/8xx/bin/ppc_8xx-ld -T arch/ppc/vmlinux.lds -Ttext
> 0xc0000000 -Bstatic arch/ppc/kernel/head_8xx.o init/main.o init/version.o
> \
> 	--start-group \
> 	arch/ppc/kernel/kernel.o arch/ppc/mm/mm.o arch/ppc/lib/lib.o
> kernel/kernel.o mm/mm.o fs/fs.o ipc/ipc.o arch/ppc/math-emu/math-emu.o \
> 	drivers/block/block.o drivers/char/char.o drivers/misc/misc.o
> drivers/net/net.o drivers/media/media.o  arch/ppc/8xx_io/8xx_io.o \
> 	net/network.o \
> 	/usr/local/src/linux-2.4.2/lib/lib.a \
> 	--end-group \
> 	-o vmlinux
> arch/ppc/kernel/kernel.o(__ksymtab+0x210): undefined reference to
> `sys_ctrler'
> arch/ppc/kernel/kernel.o(__ksymtab+0x218): undefined reference to
> `kd_mksound'
> 
> That's my last .config I used to test, it's very simple, has only the
> modules enabled, but no modules selected. And when I use the same .config
> but with only the modules disabled :
> 
> from this:
> 
> CONFIG_MODULES=y
> CONFIG_MODVERSIONS=y
> CONFIG_KMOD=y
> 
> to this:
> 
> # CONFIG_MODULES is not set
> 
> it works!
> 
> I would thank any help.
> 

After some more tests I discovered that the problem was not about the mtd
patch. But only with the linux kernel 2.4.2.

The problem now is this:

The Linux Kernel 2.4.2 don't build for the MPC8xx BSE-IP Engine with
modules enabled.


.config attached.


Forgive the misunderstanding.

Best regards,

Marcio Koch
koch@xxxxxxx.br
PUCRS/ELinux

.config